11

I'm getting this error while booting and my computer won't start.

a tpm error (7) occurred attempting to read a pcr value

I installed CentOS 7 on a z400 workstation computer. I was working on it and mounted a USB device from terminal and rebooted the computer, then this problem occurred.

4
  • Do you have encrypted disks, and if so how are they encrypted (the point is, are they using a key in the TPM)? Do you rely on secure boot? Commented Aug 25, 2016 at 22:25
  • I dont think, cause i installed it almost with defaults. If not is there any way to see it?
    – AUREL
    Commented Aug 26, 2016 at 14:47
  • 1
    Have this on a Fedora 24 on a Fujitsu D2778-C1 Workstation. It appears in the kernel log, but the machine boots nevertheless. Commented Jan 28, 2017 at 22:19
  • 1
    I also see this message on a HP probook installed with centos7, but no problem for booting
    – tonioc
    Commented Feb 13, 2017 at 12:49

5 Answers 5

7

In case if somebody facing this issue in the boot time , the bellow steps fixes my issue :

first of all I was getting that error Message while booting :

a tpm error (7) occurred attempting to read a pcr value

and I've fixed it by :

within your grub menu choose

Advanced options for ubuntu

from the list which will pop up choose the recovery mood :

Ubuntu, with linux x.x.x.x (recovery mood)

you will boot your system in the recovery mood, which will pop up some errors to you.

one of those errors in checking your file system :

failure file system check of the root filesystem failed
...
The root filesystem on /dev/sdaX requires a manual fsck

in my case it was /dev/sda2 ,

you need then to run the following command :

fsck /dev/sdaX

while sdaX is your boot driver.

a lot of prompts will ask you about fixing the issue,

hit yes for all those messages , after you finishing the fix , reboot your system :

$ reboot

and it should works fine.

3

I had the same problem with Ubuntu 16.10 on an HP Compaq 6710b - ironically, enabling the TPM in the BIOS fixed the problem. I initially tried disabling it but enabling and allowing the OS to manage it fixed the issue.

1

Disable TPM security from your BIOS settings , boot with nomodeset

Then add blacklist tpm_tis to your /etc/modprobe.d/blacklist.conf

1
  • What is nomodeset, how to boot with nomodeset?
    – AUREL
    Commented Aug 26, 2016 at 14:48
0

I had the same problem and it just booted after 5 seconds and i did nothing to the bios and i'm using Ubuntu 16.04 as my main computer yes my main computer not a virtual machine and it just came out of a menu that showed up when i booted my compuer up it said use the up and down arrows and on the top it said *Ubuntu

0

I have not TPM but TCG. It was Inactive (see help message at the picture below) and I chosen Disable because I really don't know what security feature will activate and the message at boot is gone. Picture: Lenovo-Bios-Setup-Utility: Security tab -> TCG Feature Setup

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .