1

I can't understand what's wrong. My fstab looks like this:

UUID=843671A53671993E /mnt/toshiba ntfs defaults,uid=1000,gid=1000,dmask=027,fmask=137 0 0

/mnt/toshiba (and sub-folders) permissions are:

Access: (0750/drwxr-x---)  Uid: ( 1000/      pi)   Gid: ( 1000/    pi)

Event with all these set, when trying to write on /mnt/toshiba with the user with gid=1000, I get "Permission denied". The filesystem is NTFS.

1

kernel filesystem ntfs does not support writes.

you must use ntfs-3g, which actually runs in userspace (FUSE).

I think you can use all the same options and everything will work. You might benefit from a quick look at the docs to see the most common gotchas though.

I'm surprised this is the problem though, I expected people didn't build kernels with ntfs anymore due to this reason, so you wouldn't have gotten this far with it.

  • You're right. I was using ntfs instead of ntfs-3g, which I had to manually install. I'm using Debian Jessie (Rasbian Jessie "Lite"). This has not resolved my problem, though. Even if uid=1000,gid=1000 are set, the filesystem keeps mounting with uid=0,gid=0. This is really weird.. – user102035 Aug 24 '16 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy