I'm accessing a ARM board from Linux via ethernet cable. The connection works.

For this, I use the following configuration

macabeus@acer ~ $ sudo ifconfig eth0 netmask up

And then...

macabeus@acer ~ $ telnet
Connected to
Escape character is '^]'.

BusyBox v1.1.3 (2007.07.23-13:22+0000) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

/ #

For some reason, after a few seconds, Linux resets the connection and delete my configuration. I think he detects that he can not have Internet connection and kills the hope of getting though, I do not want it.

How to solve this problem?

I'm using Linux Mint.

  • Is there a NetworkManager or DHCP client daemon lurking anywhere? – thrig Aug 24 '16 at 20:05
  • @thrig Yes. macabeus@acer ~ $ sudo NetworkManager -> O NetworkManager já está em execução (pid 994) – Macabeus Aug 24 '16 at 20:10
  • Okay, what's the NetworkManager configuration set to do, especially for eth0? (Or do you need it?) – thrig Aug 24 '16 at 20:19
  • @thrig I used the following command, and returns nothing: macabeus@acer /etc/NetworkManager $ sudo grep -r "eth0" . That's how you search settings in NetworkManager? I have no experience. – Macabeus Aug 24 '16 at 20:53
  • What distribution is running on that board? Different distributions set up networking (including where NM looks for settings and how NM reacts when something else tries to manage the network) differently. – Gilles 'SO- stop being evil' Aug 24 '16 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.