0

I have Centos 7 running the 4.7.1 kernel (elrepo-ml) on an intel NUC with intel HD Graphics i915.

I'm trying to run Chrome in full screen mode google-chrome --full-screen --kiosk http:192.168.2.20 (just a local server with the default apache2 page) and it works most of the time, but randomly (every second to fifth time) it doesn't fully display the page and looks like this:

screencap

You can see that chrome "thinks" it's full screen because of the way that the page is rendered.

One interesting behavior is that if I ALT-TAB to antoher window (hidden in the screen shot), then the page will render full screen under the window just brought to the front.

There is nothing interesting in X.org logs -- the same lines are repeated in both successful and unsuccessful full-screen attempts. (The same lines are logged in /var/log/gdm/ when gdm is in debug mode).

[352467.250] GetModeLine - scrn: 0 clock: 148500 [352467.250] GetModeLine - hdsp: 1920 hbeg: 2008 hend: 2052 httl: 2200 [352467.250] vdsp: 1080 vbeg: 1084 vend: 1089 vttl: 1125 flags: 5

I've tried to force a refresh (which may be what ALT-TAB) programatically with xrefresh, but that doesn't' make any difference.

What could be causing this behavior and what can I do to consistently get a full screen image?

Edited to add more system details:

  • Hardware: Intel NUC NUC5CPYH Processor
  • Intel Celeron N3050 with Intel HD Graphics

Driver:

$ modinfo i915 | grep version srcversion: 4F4A9108A6D94B8919E3154 vermagic: 4.7.1-1.el7.elrepo.x86_64 SMP mod_unload modversions

Hardware:

$ dmesg | egrep "i915|[Gg]raphic" [ 0.000000] Reserving Intel graphics stolen memory at 0x7cf00000-0x7eefffff [ 2.356158] [drm] Memory usable by graphics device = 2048M [ 2.498705] [drm] Initialized i915 1.6.0 20160425 for 0000:00:02.0 on minor 0 [ 3.284294] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device [ 6.301736] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])

  • Is that only happening when you have other windows open? – Julie Pelletier Aug 24 '16 at 1:41
  • @JuliePelletier - it happens when no other windows are open (chrome is started --full-screen is started directly from the gnome-shell. – MikeV Aug 24 '16 at 3:19
  • I'm not sure why but it's a display driver problem. Did you try a different driver? What is your graphics adapter model? – Julie Pelletier Aug 24 '16 at 3:25
  • @JuliePelletier - I've updated the original question to provide more details on the system configuration. I haven't tried a different driver - what would be a good alternative? – MikeV Aug 24 '16 at 16:51
  • At this point I don't have a direct answer. If I were you, I'd try a different window manager to see if it could be related to the issue or not. If not, I'd probably more generic video drivers such as xf86-video-intel. – Julie Pelletier Aug 25 '16 at 4:00
1

I've been hitting this when maximizing/fullscreening Chrome windows, and while I don't have a solution, I do have a couple of workarounds that appearto work for me:

Simplest: Right-click on a Chrome window's titlebar, and select "Use system title bar and borders". This seems to help for me, but does introduce some ugliness in the form of odd decorators that seem out of place.

Alternative if that's not helpful:

  1. Maximize/fullscreen the window
  2. Set the resolution to a lower setting with xrandr (in my case, running: xrandr -s '1280x720')
  3. Reset the resolution to the setting you really want (in my case, running: xrandr -s '1920x1080')

At that point, my maximized/full-screen windows render properly. I can also take a maximized window, and switch it in and out of fullscreen mode without a problem. However, if I unmaximize/"restore" the window to a floating mode, and then maximize/full-screen it again, the problem reoccurs.

Switching to another window manager (xfce's xfwm4 for example) also seems to help. With that in mind, I'll sometimes switch to it (running: xfwm4 --replace), and switch back to gnome-shell when I'm done something that needs full-screen mode (running: gnome-shell --replace).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.