2

Actual message (from photo, not recorded in dnf system-upgrade log -1):

Upgrading   : glibc-2.23.1-18.fc24.x86_64 28/4874
warning: %trigger(cronie-1.4.12-1.fc21.x86_64) scriptlet failed, exit status 127
Non-fatal <unknown> scriptlet failure in rpm package glibc

It looks like the problem is some interaction between glibc for Fedora 24 and cronie for Fedora 21. Is this a problem?

sudo dnf reinstall glibc worked fine, by the way.

  • I may be wrong, haven't used Fedora since 18. Yet, I believe, you need to go F21->F22->F23->F24. That's how they make the upgrade scripts. I cannot point you to how to do it though, sorry. – grochmal Aug 23 '16 at 13:27
  • 1
    Yes, the recommended ways is F21->F22->F23->F24, because there are a lot of changes between these 4 versions to keep the update scripts up-to-date for more than the latest version. Though I did 21->23 some time ago, which worked for me. Anyway, you should rather try sudo dnf reinstall cronie, which caries the failed scriptlet. – Jakuje Aug 24 '16 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.