0

I installed a fresh copy of Fedora 24 on my older notebook (1.gen i5) a few weeks ago and (naturally) first tried to get the latest updates through dnf (sudo will be omitted here).

After a while (still running dnf) I got pushed back to the login-screen and when I logged in, all terminal-windows were gone. After a restart I noticed that the kernel hasn't been updated (though I saw a newer version had been queued and my VMs also use a newer one).

Another run of dnf update says that there are no packages available for updating. Refreshed the cash with dnf clean all but that did not help. So I tried to undo the last update by running dnf history undo <id> but I then get the message:

No package available. Error: An operation cannot be undone

The package-name varies every time I run the command.

I had that issue right after a fresh installation and so I reinstalled a few times and later used an online-installer which I booted from CD instead of USB. This worked fine and I was able to update without any error. So I thought that it was just a problem with the way I installed it (YUMI created the USB-device and I think that is not really supported). But now a few weeks later, I got the same issue.

The system hasn't been modified in any way, honestly, I haven't even used it for a while. The currently installed kernel is 4.6.4-301 and it tried to install 4.6.6.

Any ideas how to fix that or what I can check?

UPDATE: After reinstalling the system with a netinstall-image so that I start with the newest updates, it ran fine for some time. But now I got the same issues again (this time no kernel update, but same issue).

I noticed that I have some duplications by checking rpm -qa. Especially systemd hasn't been updated correctly so that I have two versions of it. I tried to reinstall it with

sudo dnf reinstall systemd -y --allowerasing --best

but that did not work (as expected).

0

Though I do not know why exactly that happened (the Fedora-QA guys are currently figuring that out), I got the answer to repair it (thanks go to Fedora-QA guys again).

  1. Check for duplicated packages by running
    rpm -qa

    It will look like:

    systemd-229-13.fc24.x86_64
    systemd-229-15.fc24.x86_64
    ...

    Best way to do this (as you may have a lot of packages) is to check for all packages that have been touched by the update. To see that check
    sudo dnf history info
    It will return the packages touched by the last update.
    Now run rpm -qa | grep *package-name* to get just all packages with that name.

  2. Remove the old packages
    rpm -e *package-name* --justdb --nodeps
  3. Reinstall the new package
    sudo dnf reinstall *package-name*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.