My sound and wireless hardware are not working under my current 3.16.x kernel on my Debian 8 system. I performed:

apt-cache search linux-image

with the intention of getting the 4.x version linux kernel to try to fix this (as the hardware works fine under Ubuntu 16.04).
However it seems the choice of kernel is limited to:

linux-image-3.16.0-4-amd64 - Linux 3.16 for 64-bit PCs

I would like to install the 4.x version and have the option to switch between the current kernel and the 4.x version.
How can I do this using apt-get or a simple way that does not require manual compilation?

  • 3
    There's a 4.6 kernel in backports. Aug 23, 2016 at 6:47
  • Please add the output oflspci -knn | grep Net -A2 ?
    – GAD3R
    Aug 23, 2016 at 8:29
  • 1
    Thank you for your responses. @GAD3R: lspci -knn | grep Net -A2 03:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a) Subsystem: Intel Corporation Device [8086:9010] lspci -knn | grep Audio -A2 00:1f.3 Audio device [0403]: Intel Corporation Device [8086:a170] (rev 31) Subsystem: Intel Corporation Device [8086:2064] Kernel driver in use: snd_hda_intel Aug 23, 2016 at 9:45

2 Answers 2


Add something like

deb http://mirror.one.com/debian/ jessie-backports main contrib non-free

to your sources.list. To install the 4.6 kernel, run:

apt-get update 
apt-get install -t jessie-backports linux-image linux-image-amd64

It might depend on a few other things that can also be found in backports, you might have to add those packages names to the command line explicitly. Apt will automatically track the versions in backports for the packages you install from backports, and not install anything from there unless you explicitly ask for them.

And after reading the entire question: It should be possible to leave the old kernel installed, and then grub should be configured to offer you a choice.

  • Thank you. Your answer helped me get the 4.x kernel and grub was automatically configured. Annoyingly however, X Window fails to start with latest kernel :) I'll have to look through the logs... Is this normal behaviour for a kernel upgrade? Aug 25, 2016 at 3:18
  • It's quite common that people have to use newer kernels to make X work (well), so I suppose it's not surprising that it can break X too. Maybe you just need to install xserver-xorg-<driver> from backports too, <driver> depends on your hardware. Aug 25, 2016 at 6:58
  • Currently, jessie-backports is in archive, and that line of sources.list won't work. See this answer. Jan 26, 2022 at 20:08
  • The question, and my answer is from 2016. I don't think many people will expect that to work. Jan 26, 2022 at 20:31

There are more recent kernels in the backports archive. Do note that the support for packages in that archive are at a lower level than the packages in stable, though.

To enable that archive, you need to add a line like the following to your /etc/apt/sources.list file:

deb http://your.mirror.here/debian jessie-backports main

Where you obviously replace your.mirror.here by your nearest archive mirror.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .