1

I have a fresh install of openSUSE (tumbleweed) that I am trying to access via ssh from my Windows 7 box on my local home network. I can ping the boxes from each other successfully. I have edited the /etc/ssh/sshd_config file on the openSUSE box and changed the port to 2223. I have added the line AllowUsers (mylogin) to ssh_config. PermitRootLogin is set to no. PasswordAuthentication is set to yes. I generated a public key on my windows machine and copied it to the openSUSE machine via a flash drive and added it to my .ssh/authorized_keys, but my understanding is this shouldn't be needed if I have PasswordAuthentication set to yes.

I have done these things after researching different solutions on the internet but I can't seem to find a solution to my problem: I can't login to my openSUSE box from Windows via Putty. I can connect to a session but I get 'Access Denied' everytime I attempt a login.

edit* I can login via ssh on my linux box from my linux box using

ssh openSUSEcomputername -p 2223
  • Firewall/Apparmor problem? and/or windows firewall problem? – mdpc Aug 22 '16 at 21:18
  • Is something like iptables enabled by default while installing suse ? – MelBurslan Aug 22 '16 at 21:19
  • from windows, open up a command prompt and try running telnet suselinuxservername 2223 what do you see ? – MelBurslan Aug 22 '16 at 21:20
  • @MelBurslan the response to telnet is a blank screen that says SSH-2.0-OpenSSH_7.2 and has a blinking cursor on the next line. If I don't type anything I get Connection to host lost after a couple minutes. – doval Aug 22 '16 at 21:32
  • Then you don't have a firewall problem. Try shutting down sshd and starting in debug mode for one single instance with sshd -p 2223 -D -ddd -e and try logging in from your windows machine, while watching the log screen on your linux box. It may give you the indication why it is giving access denied message. – MelBurslan Aug 22 '16 at 22:50
1

ugh I knew it was something simple... when I was logging in i used (username)@(servername). after disabling UsePAM and testing connection I found that the login attempt was automatically appending the servername to the end of the login I entered, giving the wrong login. i logged in using just the username and was successful. renabled UsePAM parameter and was successful.. solved. thanks to all that responded!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.