1

I have a Debian Jessie OS on a Dell Vostro 5870. Every time I try to connect to my Bluetooth speaker, I get this error from /var/log/syslog:

bluetoothd[1326]: a2dp-sink profile connect failed for C8:84:47:F7:73:1E: Protocol not available

Another error can be seen by dmesg:

[    4.435796] Bluetooth: hci0: read Intel version: 370810011001140d00
[    4.436742] bluetooth hci0: Direct firmware load for intel/ibt-hw-37.8.10-fw-1.10.1.14.d.bseq failed with error -2
[    4.436748] Bluetooth: hci0 failed to open Intel firmware file: intel/ibt-hw-37.8.10-fw-1.10.1.14.d.bseq(-2)

My Wi-Fi card is (which includes Bluetooth):

Network controller: Intel Corporation Wireless 7265 (rev 59)

Another important thing is that the Bluetooth card searches and shows the correct device (gnome Bluetooth panel) but when I click on "connect" it doesn't work.

2 Answers 2

1

1) First of all. We need to install the intel drivers pack:

apt-get update
apt-get install firmware-iwlwifi

2) After this, we need to check if all drivers needed are available, check the driver folder, searching (in this case) for ibt-hw-37.8.10-fw-1.10.1.14.d.bseq

$ ls -l /lib/firmware/intel/
total 112
-rw-r--r-- 1 root root 21198 Jun 15  2014 ibt-hw-37.7.10-fw-1.0.2.3.d.bseq
-rw-r--r-- 1 root root  3558 Jun 15  2014 ibt-hw-37.7.10-fw-1.80.1.2d.d.bseq
-rw-r--r-- 1 root root 20989 Jun 15  2014 ibt-hw-37.7.10-fw-1.80.2.3.d.bseq
-rw-r--r-- 1 root root    96 Jun 15  2014 ibt-hw-37.7.bseq
-rw-r--r-- 1 root root 10612 Jun 15  2014 ibt-hw-37.8.10-fw-1.10.2.27.d.bseq
-rw-r--r-- 1 root root    96 Jun 15  2014 ibt-hw-37.8.bseq

3) If you cannot find the driver, then we will install from another source. In my case, I downloaded the updated driver file from Arch Linux repository wich includes the file that i need

http://mirrors.n-ix.net/archlinux/core/os/i686/linux-firmware-20160730.6bc2c60-1-any.pkg.tar.xz

4) After this, we extract the file and put it on /lib/firmware/intel

5) For last, install the Bluetooth module for Pulseaudio, wich is: pulseaudio-module-bluetooth

6) Reboot the machine so the module will be loaded and will be ready to use

1
  • The link is broken. I found the archive somewhere else but it does not contain the file ibt-hw-37.8.10-fw-1.10.1.14.d.bseq.
    – flm
    Oct 16, 2016 at 20:01
0

In case you do have the correct driver installed (from this answer), but are still facing the first error:

a2dp-sink profile connect failed for XX:XX:XX:XX:XX:XX: Protocol not available

it might just be because the pulseaudio-module-bluetooth package is missing. So

sudo apt install pulseaudio-module-bluetooth

should solve the problem, like it did to me in Debian 11 (Bullseye).

Sources:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .