1

I have a CentOS 7 machine that output the following to the /var/log/secure after every machine restart. I have to manually stop and restart the nslcd service to make these errors go away.

error reading from nslcd: Connection reset by peer

1 Answer 1

-1

It appears the nslcd has lot of problems on various Linux builds / flavors. I switched to sssd and this issue is now resolved for me.

5
  • 1
    Maybe provide some details on how you solved it? Feb 1, 2017 at 19:35
  • @JamesSumners, disable nslcd, enable sssd, and use that.
    – Saqib Ali
    Feb 1, 2017 at 22:57
  • Thanks. Turns out the cause of my issue with nslcd was some typos in the configuration. Feb 2, 2017 at 2:23
  • 1
    @SaqibAli Did you mean "now resolved" instead of "not resolved"? Jun 12, 2017 at 21:49
  • this answer doesn't make sense. nslcd is full supported so there might be an true explanation for this message. Moreover you doesn't have any sources for this information.
    – Hugo
    Aug 14, 2017 at 14:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .