2

I've got a fragment of a manual file which looks like this:

.TP
.I krb5_key_file
Location of the key for this client's principal.
Note that the key file must be owned by root and mode 0400.
The default is
.I /etc/audit/audit.key

I would like to add an unformatted dot (.) at the end of this fragment.

  1. Adding a dot at the end of the last line like this

    [...]
    .I /etc/audit/audit.key.
    

    doesn't work because the dot is being underlined.

  2. Adding an escaped dot in a new line

    [...]
    .I /etc/audit/audit.key
    \[char46]
    

    doesn't work as well because a space character is inserted between /etc/audit/audit.key and the dot: /etc/audit/audit.key ..

How can I solve this?

3

There are a number of 2-character macros that let you format their arguments in two different fonts, alternating between them. In your case, you'd use the .IR macro. R means Roman, the default font.

The default is 
.IR /etc/audit/audit.key .
  • This one seems to be much cleaner than the solution by Stephen. – Mateusz Piotrowski Aug 21 '16 at 19:58
1

You can use the alternative method of setting italics/underline mode: \fI. Then \fP to return to previous font:

So you would have

\fI/etc/audit/audit.key\fP.
  • 1
    FWIW, you can also use \fB for bold in the same way – Stephen Harris Aug 21 '16 at 19:38
0

One solution is to do it like this:

The default is \fI/etc/audit/audit.key\fP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.