1

This question is an exact duplicate of:

So I was following https://www.blackmoreops.com/2014/04/08/detailed-guide-installing-kali-linux-on-virtualbox/7/ and everything was working fine until after the installation had completed of kali linux.

I set the language and everything, but it get's stuck on loading, please wait.. It's been an hour. I've tried to do the recovery route, and again it gets to this point and does it again:

[ 1.66010] Write protecting the kernel read-only data: 1152k
Loading, please wait...

Some more code (editor's note: this looks like dmesg), all the code that I can see anyways from doing recovery mode, only "Loading, please wait..." shows up normally:

[1.98774] Linux appgart interface v0.103
[1.602915] i8042: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f03:PS2M]at 0x60,0x64 irq 1, 12
[1.607831] serio: i8042 KBD port at 0x60,0x64 irq 1
[1.608941] serio: i8042 AUX port at 0x60, 0x64 irq 12
[1.60994] mousedev: PS/2 mouse device common for all mice
[1.615986] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input0

Not gonna put the numbers for the rest unless you guys need to see them just write out what they do:

rtc_cmos rtc_cmos: rtc core: registered ric_cmos as rtc0
rtc_cmos_rtc_cmos: alarms up to one day, 114 bytes nvram
ledtrig-cpu: registered to indicate activity on CPUs
NET: Registered protocol family 10
mip6: Mobile IPv6
NET: Registered protocol family 17
mpls_gso: MPLS GSO support
Using IPI No-Shortcut mode
registered taskstats version 1
zswap: loaded using pool lzo/zbud
rtc_cmos rtc_cmos: setting system clock to 2016-08-21 10:30:18 UTC
Freeing unused kernal memory: 688k
Write protecting the kernal text: 5364k
Write protecting the kernal read-only data: 1552k
Loading, please wait...

And my machine does absolutely nothing after this.

marked as duplicate by schily, Jesse_b, sourcejedi, slm linux Jul 25 '18 at 17:39

This question was marked as an exact duplicate of an existing question.

  • 1
    John, you will need to make an attempt to debug it more and/or explain in more detail what you did (that guide is pretty dated btw, kali changed a lot since 2014). Unless you're very lucky and someone attempted exactly the same installation path and solved it, it will be pretty hard to guess what is your issue. – grochmal Aug 21 '16 at 19:06
  • I really don't know how to debug it anymore. On restart I'm given two options, one with grub and one without. I chose both and get to the same point. If I chose grub, I'm hit with run grub normally, or in recovery mode. So in total 3 options all lead down the same path to this Loading, please wait... thing. Do you have any advice on how to debug it more? Thanks @grochmal – John Aug 21 '16 at 19:09
  • You could try different kernel options and trying to get into initramfs. But realistically, get a working distro before attempting to fix one. The official installation guide is quite different from the guide you're following. Moreover, understand VirtualBox parameters, they do make a difference. Preferably get an old machine (not a new machine!) and test the installation on that. – grochmal Aug 21 '16 at 19:21
  • 1
    If you are using VirtualBox, you can simply add another one and "try" different settings. Usually I never do all these VirtualBox settings for Usb, Nat, VirtualBox Additions, etc. I first install the system, unmount the iso and then do these details, to ensure a simple configured, working system. Also, why Kali 1? Kali 2.0 was released some time ago, I personally don't wanna miss gnome3 on any Debian OS. Most of the time, a fresh install is the simplest. – Ueda Ichitaka Aug 21 '16 at 20:24
  • I downloaded kali kali.org/downloads from here. I have a 32 bit system. What's the best way to do a "fresh" install? I'll try messing with the settings in a bit. – John Aug 21 '16 at 20:57