1

Though I have specified, key_mgmt as WPA-PSK, the device reads it as none. Is there any problem in device? if yes how can it be rectified.

I also used these commands to give device information about wifi.

wpa_cli -p/data/misc/wifi/sockets/ -iwlan0
add_network
set_network 0 auth_alg OPEN
set_network 0 key_mgmt WPA-PSK
set_network 0 ssid "5_18-SS-161-CH"
set_network 0 psk "1234567890"
select_network 0 "5_18-SS-161-CH"
enable_network 0 "5_18-SS-161-CH"
reassociate

when i use these commands, android device connects to wifi, but as soon as I rerun when I use the below given command and see network info it reads key_mgmt as none.

cat /data/misc/wifi/wpa_supplicant.conf

is it possible to give details of the AP permanently, so that the device doesn't forget it at all even after I diable and enable wifi it should remember the same information, using following commands:

ctrl_interface=/var/run/wpa_supplicant
network={
ssid="hdwireless"
key_mgmt=WPA-PSK
group=TKIP
pairwise=TKIP
proto=WPA
psk="hdwirelesskey"
priority=1
} 
0

Store your setup to the wpa_suppilcant.conf file using the following command:

save_config

The command should save your config and return OK.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.