0

How do I disable the alt+tab switching between Gnome 2 windows?

Which part of Gnome is responsible for doing the alt+tab ? metacity ?

I am using Gnome 2.16.0 (RHEL5). I do not see any keyboard shortcut for alt+tab, when listing the configuration database:

$ gconftool-2 -R / | egrep -i alt
  mouse_button_modifier = <Alt>
  switch_to_workspace_down = <Control><Alt>Down
  switch_to_workspace_left = <Control><Alt>Left
  switch_to_workspace_up = <Control><Alt>Up
  switch_to_workspace_right = <Control><Alt>Right
  move_to_workspace_up = <Shift><Control><Alt>Up
  maximize = <Alt>F10
  unmaximize = <Alt>F5
  minimize = <Alt>F9
  begin_move = <Alt>F7
  move_to_workspace_down = <Shift><Control><Alt>Down
  move_to_workspace_right = <Shift><Control><Alt>Right
  move_to_workspace_left = <Shift><Control><Alt>Left
  begin_resize = <Alt>F8

On the web there are some questions relating to alt+tab and Gnome 3, but nothing about completely disabling alt+tab in Gnome 3.

Background: I am running linux in a RealVNC window on a Windows10 pc, and would like alt+tab to switch between my Windows10 windows, and not between Gnome windows.

0
gconftool-2 --type string --set /apps/metacity/global_keybindings/switch_windows disabled

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.