1

Using the freshplayer wrapper one can use Chrome's flash player on Firefox and Firefox based browsers. The reason being that Adobe's flash is outdated.

For Ubuntu 16.04 and 15.10. And possibly _Ubuntu based distros?

sudo apt-get install pepperflashplugin-nonfree browser-plugin-freshplayer-pepperflash

After that, attempt to play some live streaming content on the web, this occurs:
~ Failed to load "libpepflashplayer.so".
~ Freshwrapper is a translation layer which needs
~ PPAPI plugin backend. Ensure your system have
~ "libpepflashplayer.so" available.
which find couldn't locate it anywhere in the system.
How to solve this?

2

Chrome has started installing pepperflash in the users' home directories instead of where freshwrapper is used to looking for it.

You can fix it by editing ~/.config/freshwrapper.conf to point to the .so file installed by chrome.

If you haven't already, you will need to [apt-get] install chrome [google-chrome-stable] for this to work, as well as browser-plugin-freshplayer-pepperflash . The pepperflashplugin-nonfree package, which in theory would work instead of installing chrome, appears to be broken.

Once you've installed freshplayer, you can find a template of freshwrapper.conf in /usr/share/doc/browser-plugin-freshplayer-pepperflash/freshwrapper.conf.example most likely.

I copied that file to ~/.config/freshwrapper.conf and then changed just one line to this:

pepperflash_path = "/home/[myusername]/.config/google-chrome/PepperFlash/24.0.0.186/libpepflashplayer.so"

You'll need to see exactly what path your libpepflashplayer.so is and use that.

This is a short term solution since presumably updates to chrome could move this (i.e., if 24.0.0.186 is a build number, this is likely to change often). Hopefully freshwrapper will be updated to look in ~/.config/google-chrome/... soon and this fix will become unnecessary (at which point you'll need to delete freshwrapper.conf again to enable the proper behavior...)

This is what worked for me, but I've only done a minimal amount of research on it to get it working, so there may be a more correct solution which I'm unaware of...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.