I've been trying since some time in February, but I haven't been able to get my 980 ti to recognize my monitor's native 1080p resolution. I can't remember when this started. I first tried fixing it after messing around with a crappy KVM that I ended up returning, but I've had the graphics card since fall 2015, and it may have started then. Here's what I've tried so far in no particular order:

  • installing Nvidia's drivers (opens up a few more resolution options, but still doesn't give me 1080p)

  • reinstalling Ubuntu

  • installing the previous LTS release of ubuntu (14.04 iirc, and I think I even dug up an old driver from around the time that version was released)

  • trying various flavors of Ubuntu. My favorite is Ubuntu Gnome, but I've tried the default unity as well.

  • trying other flavors of Linux (Mint and Fedora)

  • updating the kernel manually

  • using an HDMI cable instead of the DVI cable. This one seemed to work for a while, but broke somehow--perhaps thanks to an update

I'm about to try installing SteamOS, since I think Valve uses in-house graphics drivers that might work out.

1 Answer 1


The EDID on my monitor was corrupted. My Macbook pro stopped displaying at all on the monitor several months after writing the above post, which prompted me to test both my desktop and laptop on a vizio TV. Both worked flawlessly. I didn't mention above that I was also running Windows 10 and Linux on the same machine. Windows was able to display correctly the whole time, which made me think it was something besides the monitor. Turns out that MacOS, Linux, and Windows all react differently when the EEPROM holding the EDID information is corrupted. Windows seemed to keep working normally, Mac eventually quits working altogether, and Linux will display but in the wrong resolution.

I bought a new monitor and everything works fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .