3

I have two Samba servers. One is running Ubuntu 14.04 with Samba version 4.3.9-Ubuntu; the other is running Fedora 24 with Samba version 4.4.5.

I'm able to store and use a Quickbooks 2016 company file on the Ubuntu server, but not on the Fedora server. I can read and write other files on both, but Quickbooks has some sort of connection issue when creating and opening Quickbooks files on the Fedora server. The error codes are -6000, -832, and -83. I tried to use Quickbooks from Windows 8.

Fedora's smb.conf:

netbios name = micah
hosts allow = ALL
...
[global]
    workgroup = SAMBA
    security = user

    passdb backend = tdbsam

    printing = cups
    printcap name = cups
    load printers = yes
    cups options = raw
...
[quickbooks]
    path = /home/shares/quickbooks
    valid users = @quickbooksgroup, matts, liquidadmin
    guest ok = no
    writable = yes
    browsable = yes
    force create mode = 0777
#   force security mode = 0777
    force directory mode = 0777

Ubuntu's:

[global]
    unix password sync = yes
    passwd program = passwd %u
    workgroup = WORKGROUP
    server string = %h server (Samba, Ubuntu)
    dns proxy = no
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 0
    panic action = /usr/share/samba/panic-action %d
    server role = standalone server
    passdb backend = tdbsam
    obey pam restrictions = yes
    unix password sync = yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    pam password change = yes
    map to guest = bad user
[shared]
    path = /home/shares/shared
    valid users = @everybody
    guest ok = no
    writable = yes
    browsable = yes
    force create mode = 0777
    force security mode = 0777
    force directory mode = 0777

What's the difference between the two servers?

3
  • 1
    There are so many differences I wouldn't know where to start. If you want the same setup, why not make both very similar? Aug 19, 2016 at 20:42
  • Have you ensured the files have the correct selinux labels on fedora?
    – llua
    Aug 19, 2016 at 21:32
  • I disabled SELinux entirely on Fedora.
    – aswine
    Aug 19, 2016 at 22:49

1 Answer 1

0

I copied all of this from Ubuntu to Fedora, and it works now:

unix password sync = yes
passwd program = passwd %u
passwd program = /usr/bin/passwd %u
workgroup = WORKGROUP
server string = %h server (Samba, Fedora)
dns proxy = no
syslog = 0
server role = standalone server
obey pam restrictions = yes
passwd chat = *Enter\snew\s*\spassword:* %n\n     *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
map to guest = bad user
usershare allow guests = yes
0

Not the answer you're looking for? Browse other questions tagged or ask your own question.