2

Update: I have successfully repaired my Mint installation using the Super GRUB2 Disk, and can now boot into all my operating systems successfully. Once I was in Mint, I updated everything that needed to be, including GRUB2 and initramfs, and rebooted, and it worked perfectly. I finally have my system back to normal

Why did multiple reinstalls and reformats not work in the first place? I have performed multiple Linux installations on multiple devices without a hitch. Why did this behaviour appear to be carried over after a full reformat of the entire drive? And how can I prevent this from happening again in the (hopefully distant) future? Could this mean there may be an issue with the hard drive itself, partition or otherwise?


-Original post- I've tried reinstalling Mint 18 several times, with the same result-- it shows a bigger, distorted version of the Linux Mint boot logo and then drops into initramfs. It may be worth noting that I first encountered this problem last week, and due to this and other problems I decided to completely wipe my hard drive and start over again, reinstalling Windows 8.1 first. I then resized the drive to install Mint and Cub Linux.

The thing is, it worked fine the very first time I installed it. I could boot into Windows (which I upgraded to 10 first thing after reinstalling), Linux Mint, and Cub Linux with no problem. However, after formatting the partition as ext4 again and reinstalling Mint with the same live USB, it now boots into initramfs. I tried reinstalling the iso on the live USB and trying to reinstall again, and also deleting and recreating the partition, to no avail.

I have absolutely no idea what happened or what to do next, all I know is that I would like to be able to dual-boot again. Any help would be very much appreciated!


Edit: It may be worth mentioning that I had some problems with Grub just before this happened. I installed Mint first, placing the boot loader in the same partition as the installation, and it finished successfully. I then installed Cub Linux, with its boot loader again on the same partition, and at the end of the installation received an error stating that grub-efi-amd64-signed could not be installed. I booted into Mint, updated Grub, and from the updated menu booted into Cub. I then installed grub-efi-amd64-signed, and upon rebooting realized Cub had overwritten Mint's boot menu. I updated Grub, booted into Mint, and updated Grub again, hoping to overwrite Cub's menu. It didn't work. I then booted into Cub and purged grub-efi-amd64-signed, and booted back into Mint, and it still showed Cub's menu. I finally decided to reinstall them both, and that's when the problem in the title started.


Edit 2: Come to think of it, this whole thing was started at least partially by a botched MintPup install. I accidentally deleted all partitions, then used TestDisk to recover the partition table. All but a few partitions were intact, as TestDisk reported that two of my partitions' structures were bad. So I restored all but those two, and when I looked at my partitions the ones to the right of the ones with "bad" structure had been moved to the left, leaving several GB of unallocated space on the end of the disk. That's when Mint began booting to initramfs in the first place, but surely any issues present then should have been removed when I reformatted the drive, right?

  • Are there any messages on screen when it dumps you in to initramfs? If so, a picture might help. (We don't expect you to type a page of debug messages—a picture taken with a cell phone camera is fine.) – derobert Aug 19 '16 at 19:41
  • Nope, just the usual BusyBox info. – Wayward_One Aug 19 '16 at 20:57
  • askubuntu.com/questions/137655/… is probably the answer - a bad superblock is causing the problem. – notavailable Jan 29 '17 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.