1

I'm trying to install Linux on my new Intel 525 SSD (240gb), however none of the linux installers detect it. I've tried Debian Testing, Gentoo, Gparted live, and Arch Linux live usbs - none of them detect my ssd, only my hdd. What's interesting is that both windows 7 installation usb and already installed windows successfully see my ssd. Furthermore, in Arch Linux live usb, there is an option during boot called "Hardware Information (HDT)" and I can see my ssd there, but after actually booting the iso lsblk onlly shows my hdd and usb stick itself, but not the ssd.

What I've done:

  • Updated bios.
  • Updated ssd firmware.

What I've tried:

  • Playing with UEFI options (Legasy support, only bios, only uefi... etc)
  • Disabling/Enabling certain bios options (Virtualization, IDE/SATA modes, etc)
  • Falling back to bios defaults
  • Trying different usb sticks
  • Playing with doscsi nodmraid scandelay nosata boot options in Gentoo live usb
  • Removing my hdd thus leaving ssd alone

Yeah, and the laptop I'm doing it on is a Lenovo m50-70.

EDIT: I have just discovered that using Gentoo live usb and acpi=off setting I am able to see, mount and use my ssd (finally), but! Acpi=off disables any hyperthreading support, which is not really cool.

EDIT2: pci=noacpi allows hyperthreading, ssd is detectable. Best option so far.

  • Can you post your full dmesg output for boots with acpi=on, acpi=off, pci=noacpi. This sounds like the device needs a quirk added to the kernel so that it turns up properly. – robbat2 Mar 28 '17 at 6:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.