1

Since Debian uses firefox instead of iceweasel, apt-get update returns 404 errors with this URL:

http://mozilla.debian.net/dists/wheezy-backports/iceweasel-release/binary-amd64/Packages

I had installed firefox-esr in order to migrate to firefox and I have no problem, I can use Firefox.

I use rvm and when I try to install ruby with it, it stop the installation because apt-get update returns a error 404. Read this.

I use Kali Linux and my sources.list is clean:

#kali 2.0
deb http://http.kali.org/kali sana main non-free contrib
deb http://security.kali.org/kali-security/ sana/updates main contrib non-free

How to delete these 404 errors?

1

Find and remove line saying:

deb http://mozilla.debian.net/...

If it is not in /etc/apt/sources.list, then it is somewhere else, most probably /etc/apt/sources.list.d/*.

You can also use fgrep -r mozilla.debian.net /etc to find it.

Note that this file might be part of some old debian package (find out which with dpkg -S /etc/apt/sources.list.d/blahblah.conf) - in that case, it is probably best to dpkg --purge that old iceweasel package.

  • 1
    In order to solve my problem, I delete this file that contain: deb http://mozilla.debian.net/ wheezy-backports iceweasel-release The location of this file is /etc/apt/sources.list.d/mozilla-debian.list. – sushi Aug 23 '16 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.