1

I'm using ubuntu 14.04 and did a apt-get install phpmyadmin I went through the install process and forgot to check off an option to install it for apache2. The install didn't finish, but it must have edited something on my system and I can't seem to start mysqld anymore.

root@drupalpro:/var/log/mysql# service mysql start
 * Starting MariaDB database server mysqld                                                                                                                                                                                                                     [fail] 
root@drupalpro:/var/log/mysql# service mysql status
 * MariaDB is stopped.
root@drupalpro:/var/log/mysql# 

When starting mysqld it just says starting and then hits me back to the prompt. And mysql isn't started at all.

How would one fix something like this? This is crazy that just because I forgot to check off a checkbox it just screwed up my entire system.

enter image description here

3
  • 1
    Have you considered looking at mariadb's logs? Aug 18, 2016 at 16:26
  • Also confirm with e.g. ps fxa that it's not actually already running. Or half-running (e.g., crashed but left a process or two around).
    – derobert
    Aug 18, 2016 at 16:35
  • updated my question of the screenshot. i checked the logs. nothing changed. I'm not sure what to look for. and ps fxa doesnt grep anything with sql. Aug 18, 2016 at 18:36

1 Answer 1

0

I got it working by:

  1. Create a new virtualbox image with the same os and working mysql.
  2. I copied over the entire /var/lib/mysql folder from the broken vbox image to the new system.
  3. Rename the new mysql folder to mysql_new and copy in the old on.
  4. Load up phpmyadmin
  5. Export the database you need.
  6. delete the old mysql folder
  7. rename back the mysql_new to mysql and import it back.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .