1

I am trying to install Hue on Centos 6.6 and configure it to point to a cluster that is running on Centos 7. The yum installation does not work on Centos 6 and hence I am trying to do the installation from source as given here. When I do the make apps command, I get after a lot of warnings:

ImportError: /usr/lib64/libxml2.so.2: version `LIBXML2_2.9.0' not found (required by /root/hue/build/env/lib/python2.6/site-packages/lxml-3.3.6-py2.6-linux-x86_64.egg/lxml/etree.so)
make[1]: *** [/root/hue/desktop/desktop.db] Error 1
make[1]: Leaving directory `/root/hue/desktop'
make: *** [desktop] Error 2

I installed python 2.7.12 using anaconda install. I can clearly see `Installing LIBXML2-2.9.2-0 being installed. Not sure why this error is occuring.

enter image description here

I also get this error import eror where zlib is not imported but this can also be seen installed during the anaconda install. should I make any configuration settings. All i did while installing Anaconda was download the .sh script and run it using bash (as mentioned in the website of continuum analytics).

Someone please help me understand and resolve this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.