5
$ uname -a
Linux kali 4.3.0-kali1-amd64 #1 SMP Debian 4.3.3-5kali4 (2016-01-13) x86_64 GNU/Linux
$ lsb_release -a
No LSB modules are available.
Distributor ID: Kali
Description:    Kali GNU/Linux Rolling
Release:    kali-rolling
Codename:   kali-rolling

Recently, I download IDA Demo from hex-rays website. After downloading and extracting it, I move to the directory contents it. But when I run ./idaq command. I received:

$ ./idaq
bash: ./idaq: No such file or directory

I tried to run this command

$ file ./idaq
./idaq: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, 
interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.24, 
BuildID[ha1]=2b4f4a30e791c6fa175a4d44c868ea9ac8f9d7da, stripped

Then I knew it is a 32-bit object file. After some Google search, I go to this page Getting "Not found" message when running a 32-bit binary on a 64-bit system, but these instructions don't help me anything.

My question is how I can run it.

P/s: My question is not elegent, if you don't like it, just press downvote.

5

You need to enable the i386 architecture and install the appropriate libraries for IDA:

dpkg --add-architecture i386
apt-get update
apt-get install libpcre3:i386 libxdmcp6:i386 libc6:i386 libffi6:i386 libxcb1:i386 libgcc1:i386 libxau6:i386 zlib1g:i386 libx11-6:i386

(Look at the output of ldd idaq and use apt-file to find packages providing the missing libraries.)

1

Oh I think I must install gcc-multilib first by:

sudo apt install gcc-multilib

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.