I had a RAID5 volume in Centos7, the number of disks were 3 in the array. Now I am trying to grow the RAID5 volume with additional 1 disk but getting error while growing the RAID5 volume.


# mdadm --grow /dev/md0 --level=5 -n 4

mdadm: Need to backup 3072K of critical section..  
mdadm: Cannot start reshape for /dev/md0  
  • 1
    dmesg? mdadm --examine /dev/sd?1? Which mdadm version and try to build the latest one from git regardless. You could also crank up the /sys/block/md0/md/stripe_cache_size to 2048 or more. Maybe try a --backup-file too (make sure not to lose it so put it on a disk but not on the md0 itself) Aug 17 '16 at 10:13
  • Frostschutz, Thanks for your help, It worked after updating the mdadm version to v3.3.4 Thanks, Sourav Maity
    – Sourav
    Aug 18 '16 at 5:57

It worked after updating the mdadm version to v3.3.4.

Thanks to Frostschutz.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.