0

Our server (Ubuntu 14.04) has recently been migrated to a new web server network. It has been assigned a DNS name and an IP address which will be assigned to it by the DHCP server (static addressing via DHCP). Our team was told that we would need to

release/renew its IP lease configure the server to use automatic DHCP settings in order for the server to pick up its new IP reservation.

Here is what I've tried to do that:

After setting /etc/network/interfaces to:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

and running sudo ifdown eth0 && sudo ifup eth0, the system hangs on the DHCPDISCOVER messages so I'm guessing it can't reach the DHCP server. The same thing happens after reboot and after sudo service network-manager restart.

(By the way,ethtool eth0 prints out the line Link detected: yes so I'm assuming our ethernet cable is plugged in to the socket corresponding to eth0)

I also tried:

sudo dhclient -r eth0
sudo dhclient -v eth0

but the second command hangs on the DHCPDISCOVER messages as well.

I'm lost as to what else I could try, any suggestions? Do I need to specify the DNS server name anywhere?

Note: if this is any help, before I started trying to configure automatic DHCP, /etc/network/interfaces only contained

auto lo
iface lo inet loopback
2
  • Do you have firewalls enabled to block the offer message? Do you see the packet if you tcpdump -i eth0 ? If not, You need to work with your network team to find out why you're not seeing the OFFER message. Aug 15 '16 at 17:21
  • FWIW, DNS is much farther on down the networking process, so it shouldn't have any bearing on this issue. The onus is still on your networking team (or you, if you've been doing bad firewall ju-ju) to get the OFFER packets out to you.
    – Thomas N
    Aug 15 '16 at 21:13
0

Turns out the networking team had misconfigured the network jack the machine was connected to, which explained why the machine wasn't receiving the OFFER packets.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.