4

The polkit-gnome-authentication-agent-1 doesn't autostart while it has correct /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop file with this content

[Desktop Entry]
Name=PolicyKit Authentication Agent
Comment=PolicyKit Authentication Agent
Exec=/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
Terminal=false
Type=Application
Categories=
NoDisplay=true
OnlyShowIn=GNOME;XFCE;Unity;
X-GNOME-AutoRestart=true
AutostartCondition=GNOME3 unless-session gnome
X-Ubuntu-Gettext-Domain=polkit-gnome-1

The user doesn't have a ~/.config/autostart/polkit-gnome-authentication-agent-1.desktop file

This breaks synaptic-pkexec and other tools that rely on policykit.

Problem seems similar to this, but this post is without resolution.

Launching process manually works and functionality is restored for that session or until the terminal used to launch the process manually is closed.

Here are dpkg.log and apt history.log

  • On what version of Mint? What packages were upgraded between the time it worked and the time it didn't work (look in /var/log/apt/history.log* and /var/log/dpkg.log*)? – Gilles Aug 15 '16 at 23:00
  • Over 1000 packages were upgraded, added, removed between mint 17.3 and mint 18. I edited the question to include the logs. – Zulgrib Aug 17 '16 at 21:24
0

Problem was due to /proc mount option hidepid. Mint 17.3 to 18 changed the init system to systemd and systemd has no support for hidepid.

0

I had same problem on Ubuntu 18.04 after installing xfce4.

The problem was that no PolicyKit Authentication Agent was installed - or at least not one that xfce recognised.

The solution is to install one:

$ sudo apt install policykit-1-gnome

That's it.

.

That installed the package: /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1.

It seemed to update the autostart list.

It was necessary to restart. Because running the file from terminal didn't work. Someone had written somewhere to run it from an xterm. I had run it from the terminal emulator that comes default in Ubuntu and is still default after installing xfce: gnome terminal.

There is such a thing as 'xfce-polkit' and 'xfce-polkit-git'.

But Debian reports, in it's account of the package policykit-1-gnome, that xfce still uses the gnome polkit agent:

This implementation was originally designed for GNOME 2, but most GNOME-based desktop environments, including GNOME 3, GNOME Flashback, and MATE, have their own built-in PolicyKit agents and no longer use this one. The remaining users of this implementation are Cinnamon, XFCE and Unity.

Other accounts of this problem:

http://lovingthepenguin.blogspot.com/2016/10/fixing-packagekit-authentication-in.html https://fransdejonge.com/2017/01/fix-no-gksudo-permissions-prompt-on-gparted-synaptic-mounting-drives-etc-in-debian/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.