1

I have an HP r007 tu laptop with preinstalled Win8.1. I installed Debian-Jessie derivative along with Win8.1. Its Ralink RT3290 wireless card is neither showing up in device manager in Windows nor in debian. I tried ifconfig wlan0 up but it does nothing, gives this message:

wlan0: ERROR while getting interface flags: No such device

I then tried

rfkill unblock wlan

even that didn't worked. How can I get it to function properly?

Even when it detected WiFi networks, it was a poor performer, needed to reset it often at that time. Can hardware failure be a possibilty?

2
  • If supplied hardware doesn't function even in the supplied, pre-installed operating system, get it working there first before trying to get it to work in a different operating system. Even more so in your case because Debian in particular can be finicky about hardware that requires firmware blobs, which many wireless network cards do.
    – user
    Aug 15, 2016 at 11:49
  • But there is no wireless card showing in device manager in windows, and I hadn't disabled it manually, it just disappeared all of a sudden. I only came to know about it when wireless stopped working in linux and when I checked in Windows it wasn;t showing there either.
    – KumarAnkit
    Aug 19, 2016 at 8:21

1 Answer 1

0

There's usually a switch on the laptop case, sometimes at the front, sometimes on a side. It turns the wireless on and off. That would be the first thing I'd check.

1
  • There is no hardware switch to control wireless card in my HP RT 007tu laptop.
    – KumarAnkit
    Sep 7, 2016 at 17:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .