-1

This is what I get when I try to run steam on my Linux Mint 18 system:

$ steam
Running Steam on linuxmint 18 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)

I'm using an AMD graphics card with default mint drivers, because as we all know AMD does not support newest versions of Ubuntu/Mint with official drivers.

Also, I have installed wine, steam, steam-launcher and tried all the fixes with fonts, moving something in steam folders etc.

I tried ALL possible fixes I could find in the internet and yet I still get the error.

What I tried so far:

  • installed wine
  • installed fonts
  • tried to move steam folders around
  • tried to install amd proprietary drivers on mint 18, no way to get them working
  • updated kernel
  • modified steam.sh
  • reinstalled steam like 20 times
  • the "LD_PRELOAD" fix
  • installed some libraries
  • tried to run steam in nomodeset and modeset.radeon=1

All of these did nothing, and steam is not working After some of the fixes it throws the X server problem, after some it throws the one mentioned above.

I have no idea what to do now, does anyone have any ideas?

@EDIT Yesterday I have downloaded all -dev libraries using userscript. This did not help

migrated from askubuntu.com Aug 13 '16 at 18:31

This question came from our site for Ubuntu users and developers.

  • Are you following a specific guide? Also how does xsession errors (~/.xsession-errors) and xorg log (/var/log/Xorg*log and/or ~/.local/share/xorg/Xorg*log) look? – grochmal Aug 14 '16 at 0:51
  • xorg in var/log: link , xorg in local/share: [link] (pastebin.com/iUt3dVq4), xsession errors: link – Karol Szustakowski Aug 14 '16 at 7:02
  • Also no, im not following any specific guide because all of them seem to provide just small answer in terminal that requires to do something or move something in steam folder – Karol Szustakowski Aug 14 '16 at 7:08
  • The important lines in xorg log are always errors (EE), it might be useful to edit the question and add them. The important one is that the acceleration method "galmor" cannot be loaded. You could add a Device section to xorg.conf and change it to none. But really, I would change the driver. xf86-video-amdgpu is just too new,it fails a lot (for example now), mint should have a package with the old xf86-video-ati driver. – grochmal Aug 14 '16 at 23:17
  • @grochmal I had both installed. I uninstalled xf86-video-amdgpu(in synaptics) is it the right way to do this or i should purge it or something? – Karol Szustakowski Aug 15 '16 at 8:11
0

Because the fglrx driver isn't supported on linux mint 18 , it is not possible to install steam, you can get some informations about the prerequisites you need from here or here

Important information

The AMD Catalyst (fglrx) drivers are not compatible with Xorg 1.18, which is the version used in Linux Mint 18.

These drivers are proprietary and so their code is not available. AMD indicated they no longer wanted to support them and urged their customers to use open-source drivers instead.

If you are using an ATI GPU in Linux Mint 18, the operating system will either select the Radeon or AMDGPU drivers for you, and these are installed by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.