1

I made the stupid mistake to install jack2 while using pulseaudio. The audio wasn't working at all (and I realized I didn't need Jack) so I decided to remove jack2. Now I do have sound (with the laptop's built in speakers), but pavucontrol is not loading (frozen at Establishing connection with pulseaudio. Please wait..." and I get this when I run "pulseaudio"

~>$ pulseaudio 
E: [pulseaudio] ltdl-bind-now.c: Failed to open module module-jack-sink.so: module-jack-sink.so: cannot open shared object file: No such file or directory
E: [pulseaudio] module.c: Failed to open module "module-jack-sink".
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

How can I remove all that depends from jack? I want to run plain pulseaudio.

I'm using arch linux

Thanks!

2 Answers 2

2

I managed to solve it removing all local config files from ~/.config/pulse and ~/.pulse Now it works perfectly

1

It looks like pulseaudio still tries to load the jack module. Check if you have pulseaudio-jack installed and remove it if appropriate. The default pulseaudio config that Arch ships with will try to load the module if it is installed, check /etc/pulse/default.pa and /etc/pulse/system.pa for "load-module". Note that if you use mpv or mplayer or a lot of related software, these packages will actually depend on jack (not jack2), so in this case you'll additionally need to reinstall jack (which conflicts with jack2).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .