0

I'm trying to install Fedora 24 side to side to Windows 8.1. I previously was running Debian 8 next to Windows and wanted to swap to Fedora. I'm trying to install from a USB live distro; some info:

  • The ssd has two windows partitions and about 90GB of unallocated space.

  • If I choose the automatic partition option, the installer complains that there is no free space available.

  • If I partition the space myself, the installer complains about not having a /boot/efi partition available (even if I specifically allocate one in the installer).

  • It's an ASUS motherboard and I've got fastboot disabled.

  • I also deleted the PK keys to disable secure boot and choose other OS in the secure boot bios option.

Running sudo gdisk -l /dev/sda from the Fedora live stick gives the following output:

GPT fdisk (gdisk) version 1.0.1

Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: not present


***************************************************************
Found invalid GPT and valid MBR; converting MBR to GPT format
in memory. 
***************************************************************

Disk /dev/sda: 488397168 sectors, 232.9 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 70D91666-A3FE-4C49-A75B-76546492EDF4
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 488397134
Partitions will be aligned on 2048-sector boundaries
Total free space is 190208301 sectors (90.7 GiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          206847   100.0 MiB   0700  Microsoft basic data
   2          206848       297166847   141.6 GiB   0700  Microsoft basic data
   3       297166848       298190847   500.0 MiB   0700  Microsoft basic data

Partition number 3 was an attempt to create a NFTS partition from Win 8 to use for /boot/efi which wasn't successful and didn't make any difference....

Any idea what else I could try?

0

So I don't know why it seems much easier to find an answer once you wrote down the question.... (thanks Ahmad)

I stubbornly booted the USB by selecting the option with the 'UEFI' prefix. Choosing the option without it fixed my issue...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.