1

I have installed Linux Kali on one of partitions of my hard drive alongside Windows 10 from USB Flash Drive (I had a bootable live version with HDD install option) and it's not booting when the flash drive from which I installed it is not inserted. When I turn on computer, GRUB appears, I choose Kali and it keeps showing me this

I really don't know what can cause this. I've tried to set kali install partition as primary and flag it to boot but it didn't work. At first I have thought that maybe this is caused by Windows which blocks hard drive after shutdown (I needed to boot to Windows and then reboot to access drives when I was using live version) but if so, then why it boots after inserting flash drive? Furthermore when it boots properly (with flashdrive) I can remove it and it works fine. I've asked this question on SU too but still got no reply.

0

It seems that you have booted through usb in UEFI mode for the installation. This is the problem. Reinstall kali and this time don't chose UEFI usb option on boot manager.Choose the other one i.e, legacy mode..and continue with graphical install.

0

During my installation, in the partition phase, the installation guide had my USB listed as "sda" first then my hard drive listed second as "sdb". After installation when I rebooted without USB I got this error, "Alert! /dev/sdb2 does not exist". Looks like my hard drive changed to "sda" upon reboot. This is what worked for me.

When in the GRUB menu hit "e" key to edit the commands. Look for "root=/dev/sdb5" in your commands.(The number in "sdb5" is the partition number, in your case "5") Change the "b" in "sdb5" to an "a" so it reads "root=/dev/sda5" You want the "root=" to point to the file system root that you want to boot. In this case probably "/dev/sda5". Do not change any other syntax. Directions at the bottom of the your screen should tell you how to save the changes and boot. Once you get into the OS, connect to the internet, open a terminal and execute the command "update-grub". This should update the commands with the UUID so now you should be able to reboot with no problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.