3

I have a funky vendor-specific IDE (Xilinx's Vivado) installed on a build server at my company.

We often need to use the tool graphically, and I'd figured that I'd be able to do it over X11 forwarding because the machine is on the same LAN as my desktop.

If I use Cygwin/X11 or XMing on Windows, the IDE forwards over X11 and works beautifully. On my machine running Fedora 23/XFCE, however, the X11-forwarding is incredibly laggy (to the point where it's unusable).

Other X11 apps (xfce4-terminal, synaptic, xeyes, etc) all forward from the remote machine with no visible lag.

I tried all of the simple stuff (using uncompressed X11 forwarding and using the weak/fast SSH encryption schemes), but nothing seemed to make a difference.

Does anybody have any advice that could help me debug/solve my app-specific X11-forwarding lag problem?

I hate having to switch to Windows to be able to use the remote app, and VNC is non-ideal, because the remote machine is a configuration-controlled build server with a minimal set of packages and services.

  • edit: The remote server is running Ubuntu 16.04 Minimal with a few extra packages and the Vivado installation. – Nicholas Clark Aug 10 '16 at 21:24
  • When using ssh X11 forwarding, did you enable ssh compression? What is your ethernet bandwidth usage when you run the app (use iptraf, ntop etc. to find out)? – Matija Nalis Aug 10 '16 at 22:36
  • I've tried both ways on SSH compression - no real difference there. The network is a 1Gbit connection - I'll check the utilization and report back! – Nicholas Clark Aug 10 '16 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.