2

I'm running Mint 18 on a Dell i7 and I have this annoying issue that I can't find where its coming from.

Every 30 seconds the display freezes for about 0.5 seconds. The issue is persistent and happens EXACTLY every 30 seconds (give or take 1 second).

This is particularly annoying when playing a game or watching a movie.

I couldn't isolate the process that may be causing this, but it wasn't there for the first week or so when I installed mint.

It may be worth to mention that I have another PC running Mint 17.1 that has the exact same issue (Also a Dell)

Anyone can think of a process that does something heavy and/or synchronous/blocking every 30 seconds?

I will provide any log file or additional info if anyone has any idea where should I look.

UPDATE: This does not happen when I CTRL+ALT+F3, even when leaving all the processes alive in the graphical window.

  • Open htop and iotop or glances in a console to check whether there is a spike every thirty seconds. – kba Aug 9 '16 at 13:09
  • thanks, but I already did that and there is no spike. It might be related to Cinnamon itself somehow or just some kind of a blocking process like a remote call that's not done asynchronously. – Tom Klino Aug 9 '16 at 13:19
  • I've got the same issue. The process is cinnamon itself, and it uses 100% cpu on one core (I have 8, so it uses one) for 0.5 seconds every 30 seconds. – Zzzach... Aug 28 '16 at 22:48
  • I should also mention that I'm using arch with cinnamon, so it isn't Linux Mint itself, it is primarily the cinnamon package that is glitching. I've tried removing all panel apps, and it didn't help at all. – Zzzach... Aug 28 '16 at 22:55
  • Keep having this issue. Forgot how I fixed it, wound up here. Will report back if I fix it again... – Ryan Yoosefi Jun 17 at 6:15
0

EDIT: What is crossed out is only a temporary fix. The problem occurred again quickly after. Going to Settings > General > Miscellaneous Options and disabling "Enable support for indicators" fixed the issue for me. I looked in the log ~/.cinnamon/glass.log and found that one of the indicators (owncloud client) kept restarting every 30 seconds, causing the issue.

Alright I solved the issue.

Rename ~/.cinnamon to ~/.cinnamon-bak.

In my case, at least, my version of ~/.cinnamon has been around for a long time. Removing this folder (causing it to be recreated), fixed the issue, and no more lag spikes every 30 seconds!

0

Had this problem with Mint 19.1. Noticed I had 2-sec freezes, which got steadily worse with time but upon testing, it affected my account only. So I deleted ~/.cinnamon from the command line. A process list simply had too much to bother isolating the offending program but at any rate, system works perfectly now.

0

Fixed, at least for my setup, external monitor over HDMI.

I fixed it by going to Menu > Preferences > General, enabling vblank, allowing compositing for full-screen windows, logging out of cinnamon and logging back in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.