2

I recently uninstalled Ubuntu 16.04 and installed Peppermint 7 instead,I had a few problems with grub not showing but fixed it by running bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi in admin cmd prompt as mentioned in this post. However I have a lot of weird options on grub(2) now...

(Previously had only 4 which were Ubuntu, Ubuntu with adv conf., windows boot manager and system setup).

Now I have:

  • Peppermint GNU/Linux
  • Advanced options for Peppermint GNU/Linux
  • Windows UEFI bootmgfw.efi
  • Windows Boot UEFI loader
  • EFI/Ubuntu/fwupx64.efi
  • EFI/Ubuntu/MokManager.efi
  • EFI/toshiba/Boot/bootmgfw.efi
  • Windows Boot manager (on /dev/sda/2)
  • System setup

I understand the first and last two, but what is all this UEFI/boot manager paths in between, and should I/how can I remove any of them (if there are unnecessary ones).

Edit: /etc/default/grub:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=-1
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
0

It seems like you are using the grub installation from Ubuntu, which probably added extra entries. Did peppermint install grub for you? If so, you're going to want to use that. The proper way of doing this would be to set it as the primary boot device in your BIOS/UEFI settings. As this is different on all computers, you will have to figure this out on your own. Usually there is a boot device order, so by moving Peppermint's grub install to the top, it will have precedence over other boot options. It is generally messy and just bad practice to use Windows' boot manager to load grub, another boot manager.

  • I think the peppermint grub menu is already the grub menu at use (since the background is that of peppermint + I completely uninstalled Ubuntu beforehead and cleaned up the boot so it would be as the same as having only windows, peppermint is based off Lubuntu which would make sense that the grub would be that of Ubuntu + I already re-ordered the device boot order in the UEFI settings), However I just wondered how can I get rid of these annoying options. And what are they even... – Elian Kamal Aug 8 '16 at 6:31
  • @ElianKamal can you post your /etc/default/grub file please? – John Leuenhagen Aug 8 '16 at 6:56
  • Updated OP with etc/default/grub. – Elian Kamal Aug 8 '16 at 10:29
  • @ElianKamal try running 'sudo update-grub' – John Leuenhagen Aug 9 '16 at 1:39
  • nothing changed – Elian Kamal Aug 9 '16 at 15:00
0

Get into EFI menu and see which entry does boot you into Windows and into Peppermint. I would say Windows UEFI bootmgfw.efi and Windows Boot UEFI loader are two analogous images, so you could delete one of them. The ones with Ubuntu can be deleted since you no longer have ubuntu. EFI/toshiba/Boot/bootmgfw.efi boots into windows, i think, but i would leave it there for keeping the warranty of the pc, and delete it if you don't care about it. Then, Windows Boot manager (on /dev/sda/2) i think also boots the same windows image, so you could delete this as well. To delete the entries, you either can do it from the EFI menu, if it is permitted, or you can try with efibootmgr; i know for sure you can do it with the EFI shell 2.0, with the bcfg command, check here.

Remember to check every entry before deleting it, i don't know for sure what they are. Also, you should have pasted /boot/grub/grub.cfg insted of /etc/default/grub, since it is the first one that stores the info of your grub menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.