2

It appears that in tmux, when I mark a pane using prefix-m, the borders of that pane are displayed with inverted colors. By this I mean the foreground color is used for the background and the background color is used for the foreground.

I can't find any way to turn this off -- man tmux seems very sparse when it comes to information about marked panes. Is there a way to disable it?

3

Looking at the source-code, apparently not. The action proceeds unconditionally through these points:

and in the last, it applies some style information but unconditionally reverses colors.

  • I've created an issue on the tmux Github repository referencing this question and answer. – Radon Rosborough Aug 7 '16 at 21:58
  • "No thanks. Given marked panes are meant to be transitory---that is, whilst performing a given command; an option for this seems overkill when the effect of the pane's border is for a short length of time only." So, it sounds like we will not be seeing this option soon, or ever. – Radon Rosborough Aug 7 '16 at 23:34
  • If you came up with a simple, non-intrusive proposed change, they might consider that. But they're probably viewing it as an unnecessary complication. – Thomas Dickey Aug 7 '16 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.