0

I've installed archlinux with GRUB but the uuid that appears in GRUB when boots is different to /etc/fstab.

I did this:

arch-root /mnt
grub-install --efi-directory=boot/efi /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg
mkinitcpio -p linux

In /boot/grub/grub.cfg only appears the correct UUID (the same that fstab). It's ok.

Why in menu GRUB appears a UUID different? How I can change it?

2
  • It might be useful to be specific what UUID you checked. Typically grub.cfg will contain one UUID used in the process of finding the kernel, then a UUID passed to the kernel+initramfs (root= option). If /boot is not a separate filesystem, the two UUIDs will have the same value.
    – sourcejedi
    Aug 6, 2016 at 19:40
  • Exactly, I tryied it that in this moment. That is the problem. Thank you and sorry
    – Lifka
    Aug 6, 2016 at 19:43

1 Answer 1

0

The problem was --efi-directory, it must be the same that grub-mkconfig

arch-root /mnt
grub-install --efi-directory=boot /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg
mkinitcpio -p linux

Solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .