I have my ASUS X556U with DualBoot between W10 and Debian Jessie, but I need to regulate the brightness.

I've been serching in Google and I found xbacklight, but I have a problem while executing it:

barreeeiroo@Debian-Diego ~> xbacklight -dec 10
No outputs have backlight property
barreeeiroo@Debian-Diego ~> 

Then I search in Google more info about the problem, and I found this post, but it causes another problem:

barreeeiroo@Debian-Diego ~> 
sudo ln -s /sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/rtsx_usb_sdmmc.4/leds/mmc0::/brightness  /sys/class/backlight
[sudo] password for barreeeiroo: 
ln: failed to create symbolic link ‘/sys/class/backlight/brightness’: Operation not permitted
barreeeiroo@Debian-Diego ~> 

I've adapted the route to my computer

Then I tried to use chmod and chown, but is the same problem.

So, my questions are:

  1. Is possible to fix that error?
  2. Is there any other method to manage brightness in Debian?


  • If you have "Operation not permitted" on chmod or chown make sure to run the commands as root (using e.g. sudo) – Anthon Aug 6 '16 at 11:40
  • The same @Anthon, not working – Diego Barreiro Aug 6 '16 at 11:49
  • I believe xrandr also has a backlight brightness setting - I think that uses a different mechanism to accomplish it, so maybe you'll have more luck that way? (note that there's a backlight brightness and 'artificial' brightness setting - make sure you have the right one) – Wyatt8740 Aug 6 '16 at 14:01
  • So, how to use xrandr in my laptop? @Wyatt8740 – Diego Barreiro Aug 6 '16 at 14:08
  • 1
    in that case as I said run xrandr without args to list outputs. – Wyatt8740 Aug 7 '16 at 5:03

Arch Linux has the following to say about xbacklight:

Brightness can be set using the xorg-xbacklight package.

Note: xbacklight only works with intel. Radeon does not support the RandR backlight property. xbacklight currently does not work with the modesetting driver.

To set brightness to 50% of maximum:

$ xbacklight -set 50

Increments can be used instead of absolute values, for example to increase or decrease brightness by 10%:

$ xbacklight -inc 10
$ xbacklight -dec 10

If you get the "No outputs have backlight property" error, it is because xrandr/xbacklight does not choose the right directory in /sys/class/backlight. You can specify the directory by setting the Backlight option of the device section in xorg.conf. For instance, if the name of the directory is intel_backlight, the device section can be configured as follows:

Section "Device"
    Identifier  "Card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"

The following worked for me on Debian Stretch LXDE.

  1. Checked the backlight directory: ls /sys/class/backlight. I happen to have intel_backlight.

  2. To get the Identifier, I ran xrandr --verbose. Mine happened to be 0x72.

  3. Checking /etc/X11/, I found no xorg.conf, so I made my own and entered the information I had found:

    Section "Device"
        Identifier  "0x72"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
  4. I then rebooted. It worked from there.

  5. Since LXDE runs openbox, I edited ~/.config/openbox/lxde-rc.xml and inserted the following keybindings:

    <!-- Increase backlight 10% -->
    <keybind key="XF86MonBrightnessUp">
      <action name="Execute">
        <command>xbacklight -inc 10</command>
    <!-- Decrease backlight 10% -->
    <keybind key="XF86MonBrightnessDown">
      <action name="Execute">
        <command>xbacklight -dec 10</command>
  • For me the best solution since xrandr could not increase the brightness. – omisson Aug 27 '18 at 18:59

Just managed to control my screen brightness in Debian with xrandr.

xrandr --output [your display] --brightness 0.8

You can find your display name by typing xrandr - you'll see it as something like "[your display] connected primary 1920x1080..."

Next up... key bindings!

  • 2
    According to man xrandr: “--brightness brightness […] However, this is a software only modification, if your hardware has support to actually change the brightness, you will probably prefer to use xbacklight.” – Denilson Sá Maia Jun 26 '18 at 14:47
  • This seems to change the color temperature too, or maybe it's cause I have Gnome Night Light on. – wjandrea May 5 at 5:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.