0

Steps I have done:

  • Installed Ubuntu Server 16.04.1 in VMware Workstation 12
  • Edited /etc/default/grub to contain GRUB_GFXMODE=1440x900 GRUB_GFXPAYLOAD_LINUX=keep
  • Run sudo update-grub
  • Rebooted; resolution was set correctly, both GRUB and Ubuntu were at 1440x900
  • Shut down
  • Took a snapshot
  • Started the VM; the resolution was no longer set correctly, GRUB was 640x480 and Ubuntu was 800x600

I did no customization during the install, before the first reboot, or between the two reboots. How do I fix this so that Ubuntu consistently runs at 1400x900?

vbeinfo in GRUB doesn't list any resolutions above 800x600.

hwinfo --framebuffer doesn't output anything at all.

Edit: I have verified this with a second install in a new VM: initially, GRUB detects higher resolutions, and this survives reboots, but does NOT survive a shut down and restart.

2

After playing about with a couple more VMs, I've traced the problem down to VMware adding

svga.guestBackedPrimaryAware = "TRUE"

to the VMX file, which indicates that VMware knows that the VM has VMware tools installed. It appears that when this flag is set, VMware doesn't expose higher resolutions via VBE, so GRUB can't use higher resolutions. Removing this line from the VMX file resolves the problem for one boot, but VMware adds it back when you shut the machine down.

This behaviour does not occur if the hardware version is 10, but does occur on 11 or 12. To fix the problem permanently, remove the line svga.guestBackedPrimaryAware = "TRUE" from the VMX file, and change the line virtualHW.version = "11" or virtualHW.version = "12" to virtualHW.version = "10".

  • Urg, took about 5 hours of faffing about, then found this, and it finally works. Thanks – Steve May 17 '17 at 15:23
  • This helped me solve my unrelated problem! Thanks! – Clonkex Dec 4 '17 at 3:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.