0

I need gcc 4.9.3 installed on my armhf debian box. But the version in the jessie repositories are 4.9.2 and the version in stretch is 5.

How can i get a particular version through the repositories?

  • Why do you specifically need version 4.9.3? – Stephen Kitt Aug 5 '16 at 11:38
1

Stretch currently has version 4.9.3, but that's about to be replaced by 4.9.4. You can get the last set of packages for 4.9.3 reliably from Debian snapshots, including for armhf. The corresponding repository is

deb http://snapshot.debian.org/archive/debian/20160415T115342Z/ sid main

(see the instructions given on the main snapshots page for details of how to use this).

  • thanks! does that mean 4.9.3 will be moving to jessie? – normad Aug 7 '16 at 3:07
  • when i select apt-get install gcc/stretch i get Selected version '4:5.3.1-3' (Debian:testing [armhf]) for 'gcc' Isn't that 5.3.1? – normad Aug 7 '16 at 3:22
  • Jessie only gets updates for serious bugs or security issues; there won't be an upgrade to GCC 4.9.3 there. To install GCC 4.9 in Strech you need to ask for it explicitly (see my first link): apt-get install gcc-4.9/stretch. – Stephen Kitt Aug 7 '16 at 14:32
  • thanks.. figured it out eventually. was hoping for a solution for this bug gcc.gnu.org/bugzilla/show_bug.cgi?id=71776 but it's still there. fingers crossed for 4.9.4 – normad Aug 8 '16 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.