1

I had dual-booted Windows 8.1 and Fedora 24, but it was already using 4 primary partitions. And I wanted to install one custom Debian version, so I wanted to triple-boot. Therefore, I create a new partition under the extended partition which holds the Fedora. Then, I installed this custom Debian version in this new unallocated space in the extended partition. After installing, it also updated the grub. When I tried to boot into this newly installed Debian OS, it was working fine, when I tried to boot into my Windows 8.1, it was working fine. But, when I tried to boot into my Fedora 24, it couldn't find kernel image, so it wasn't booting. But as can be seen from the below image of GParted, the partition holding Fedora wasn't altered or deleted, the used and unused spaces remained the same after installing the Debian, because as I said I installed it in other partition.

enter image description here

sda6 holds Fedora 24, which I had already installed. sda7 is the partition created from the unallocated space and where I installed the custom Debian OS. The above picture of GParted is when I booted from this newly installed Debian OS. Any idea how can I get back my Fedora? I mean how can I boot into Fedora too?

The error message that I get is that it cannot find the image vmlinuz-4.6.4-301.fc24.x86_64.

  • 1
    From Debian regenerate grub.cfg file : grub-mkconfig -o /boot/grub/grub.cfg – GAD3R Aug 5 '16 at 10:01
  • @GAD3R There is a grub.cfg file in Debian, and it also has a listing for Fedora. But somehow the kernel images are gone, they are not inside /boot. As I said when I start my laptop, I see all three options, Debian, Fedora, and Windows. But, I cannot boot inside Fedora. – typos Aug 5 '16 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.