0

I have puppy linux installed on a 32 bit machine. I installed python 3.5 and Pip3 libraries via puppy package manager. When I run pip3, I receive this error:

root# pip3
bash: /usr/bin/pip3: /usr/bin/python3: bad interpreter: No such file or directory

Any idea how can I fix this issue? Seems like pip3 is looking for a wrong path.

More info:

  • I don't have pip installed.
  • I have two different versions of python installed where the default one is Python 2.6.4
  • Python path

    root# which python

    /usr/bin/python


What I tried:

  • according to this answer I tried

    root# head -n1 /usr/local/bin/pip head: cannot open '/usr/local/bin/pip' for reading: No such file or directory

however as shown above, it ends in an error. Moreover there is no /usr/local/opt directory


Conclusion:

Seems like pip3 is looking for /usr/bin/python3 while python is installed in /usr/bin/python3.5

  • The real fix is of course to complain to the maintainer of the Python3 package (as opposed to complaining on Unix & Linux), but in the mean time adding a symlink python3 -> python3.5 will make your life easier. – Satō Katsura Aug 4 '16 at 12:17
  • I ran ln -s python3 -> python3.5 with success. but still I get the same error when running pip3. Strange point is when I run python3 the command is not known, however python3.5 is running. Did I make any mistake? – Woeitg Aug 4 '16 at 12:37
  • 2
    To create the symlink I'm talking about: cd /usr/bin && ln -s python3.5 python3. You might also need to restart the current terminal after that ($PATH is sometimes cached etc.). – Satō Katsura Aug 4 '16 at 12:41
  • tnx,,now it is working. If you are interested, answer this question with what is written in comment and I will accept it – Woeitg Aug 4 '16 at 12:50
  • 1
    It's a workaround for a broken package, not a solution. shrug. – Satō Katsura Aug 4 '16 at 12:51
2
$ hash -r

If you execute a command to erase something like caching, you can safely use pip. There is not time for hash command now, so do not investigate deeply.

Please note this memorable second time so as not to forget.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.