0

I am on Linux Mint 18.x Cinnamon 64-bit.

I need Lazarus IDE. There are multiple related packages. The main ones are:

fpc
fpc-src
lazarus

Man needs all these three for it to work. So I tried a week ago, and today again, to install these from repository. Ending up with an error while configuring multiple related packages.

fpc - the Compiler, some command line tools, base units and non visual components like database access

fpc-src - the sources of fpc and its packages, needed for code browsing

lazarus - the IDE, visual components and help files

EDIT:

In the official repository, there is an old version 1.6.x and I want the current version, which to date is 1.8.0, released on December 06, 2017.

0

Updated for the latest versions: Lazarus 1.8.0 and FPC 3.0.4.


First off, you need to purge the packages already installed from the official repository:

sudo apt-get purge fpc fpc-src lazarus

And purge all related packages, if there are any:

sudo apt-get --purge autoremove

We will not be installing the packages from repository, it just does not work, we have to download it over secure connection from sourceforge.net.

Once you have downloaded these 3 files:

  1. FPC Compiler:

    fpc_3.0.4-1_amd64.deb
    
  2. FPC Sources:

    fpc-src_3.0.4-1_amd64.deb
    
  3. Lazarus IDE:

    lazarus-project_1.8.0-0_amd64.deb
    

Before installation, you need to check their hashes, they need to match:

  1. FPC Compiler:

    sha256sum fpc_3.0.4-1_amd64.deb
    
    e025e13e6b7bd415d3bcc6da5e9004448b0ce593195082acd5aa1843394e1a34
    
  2. FPC Sources:

    sha256sum fpc-src_3.0.4-1_amd64.deb
    
    cdf49f0074cbb20c096de1fa71f6430883f084d71e200e63aecd8f77672e5e89
    
  3. Lazarus IDE:

    sha256sum lazarus-project_1.8.0-0_amd64.deb
    
    62024510514c2f6e16d50c1cae11c9e0329e91beecf35e5e8e5a09c43f2cdde8
    

After checking the hash sums, either click on each package and install them in GUI, or do it from terminal:

  1. FPC Compiler:

    sudo apt install ./fpc_3.0.4-1_amd64.deb
    
  2. FPC Sources:

    sudo apt install ./fpc-src_3.0.4-1_amd64.deb
    
  3. Lazarus IDE:

    sudo apt install ./lazarus-project_1.8.0-0_amd64.deb
    

Finally, you need to prevent upgrading of these packages, i.e. to hold these packages, because it might break otherwise in the future:

sudo apt-mark hold fpc fpc-src lazarus lazarus-project
-1

When I upgraded to Mint 18 (Sarah), Lazarus quit working.
The Lazarus/1.6 directory was not installed, and multiple times was unable to get it to install correctly, it should be in /usr/share/lazarus/1.6/. This is a problem with the program manager and the package itself.

Here is what fixed the problem for me:

I went into Synaptic package manager, and using the filter (keywords: lazarus and fp, I deleted all packages related to Lazarus and Free Pascal. With the fp filter, I deleted all fpc* and fp* files related to Free Pascal.

I downloaded the 3 needed files from Sourceforge, version 1.6 64-bit.

I installed the files in this order:

fpc

fpc-src

lazarus

Note: since my system is 64-bit, the link provided is to the amd64 files.
For 32-bit, you will need the i386 files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.