2

So, I was messing with some repositories last week and ran some updates that seem to have broken some things.

I am currently running Mint 17.3 and can no longer mount any remote filesystem using sshfs. This was working before the updates, and ssh still works. Running sshfs with just the host and mountpoint, I got

fusermount:  failed to access mountpoint [mountpoint]: Permission denied

Afterwards, the remote site appeared in the output of mount, but appeared in the output of ls as

d????????? ? ? ? ? [mountpoint]

If I tried to access the directory, I was told

Transport endpoint is not connected

Next, I unmounted the filesystem (even though it was not actually mounted) and then ran the same sshfs command using sudo. This time, there was a delay before the command returned a new error:

mount:  according to mtab, [site] is already mounted on [mountpoint]

The filesystem did not appear in the output of mount this time, everything from ls looked normal, and I was able to access the (empty) directory I was trying to use as the mountpoint. I tried adding -o allow_other (without sudo).

fuse:  bad mount point [mountpoint]: Transport endpoint is not connected

I have tried unmounting the filesystem and killing sshfs processes with no luck. The issue persists after rebooting as well. I use sshfs constantly and would greatly appreciate any help I can get.

  • Work checking contents of /etc/mtab – steve Aug 1 '16 at 23:20
  • It looks like the parent directory of [mountpoint] isn't executable (i.e. openable)? – steeldriver Aug 1 '16 at 23:23
  • 1
    Please show us ls -la /path/to/mountPoint/parent. I really want to see its parent's listing. – Julie Pelletier Aug 2 '16 at 0:04
  • @steve, I checked /etc/mtab, no sshfs mounts are listed. @JuliePelletier, permissions on the parent are drwxr-xr-x 25 klawson domain users 4096 – Kholby Aug 2 '16 at 13:20
  • It would have been nice to see the mounting point too (which would have been included in the output I asked you). What user are you using for the mount? – Julie Pelletier Aug 2 '16 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.