When i try to install R 3.3. on my linux, using:


It returns me the next error

configure: error: libcurl >= 7.28.0 library and headers are required with support for https

IN the folder i see some makefiles but make or make check dosent work. I checked and i have installed the last vertion of libcurl3, i use Ubuntu Based Peppermint 7. Appreciate any help.


  • 1
    I say this a lot, but why are you not using your distribution's binaries? Note also that if the versions for your distribution is not recent enough, Dirk supplies binaries via CRAN. See cran.r-project.org/bin/linux/ubuntu Aug 1, 2016 at 20:28
  • Oh, and your error probably means you need to install libcurl-dev and possibly also libcurl of the version mentioned. But I really wouldn't mess with this unless you want to. Aug 1, 2016 at 20:30
  • @FaheemMitha Hi, i didn't quite get what does it mean using my distro binaries :L , before posting the questions i try to search for the answer in the link that you posted but didn't worked for me. Best
    – Tangent3
    Aug 1, 2016 at 21:12
  • I'm not sure what is unclear about using your distribution binary packages. apt-get install r-recommended will install a basic R distribution for you. You don't have to compile from source. Aug 1, 2016 at 23:35
  • @FaheemMitha Im new at using linux, yes I do that before, but it was installed the R 3.2. wooden Xmas tree version.
    – Tangent3
    Aug 2, 2016 at 1:50

1 Answer 1


You need to install libcurl-dev to get the development libraries and headers.

Depending on the version of of the OS this might be called by different names; see http://packages.ubuntu.com/trusty/libcurl-dev for details.

  • It worked!! im not shure what I actually did installing libcurl-ocam. At last i have the R 3.3. working on my linux!, (I was deppending on my windows pc because of this)
    – Tangent3
    Aug 1, 2016 at 21:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .