0

Issue: After changing the static IP addresses on 2 units, I can no longer ping.

Configuration: OS: CentOS 7

Interfaces:

  • 2 1-GbE adapters, one used, connects to the Internet, DHCP, works
  • 2 10-GbE fiber channel adapters, one used, direct connect

Details:

I originally had the 10 GbE connections use "10.10.10.10" on one board and "10.10.10.11" on the other board. The default gateway did not matter, but I simply used "10.10.10.10". I set the MTU to 9000, prefix at 24, and disabled IPv6. Everything worked perfectly. I did not need to edit the hosts file.

After I changed the IP addresses on both units, a requirement made down upon me. One unit received an IP address of "11.33.41.15" and a default gateway of "11.33.41.0", while the other unit received an IP address of "15.5.53.51" and a default gateway of "15.5.53.254".

I keep getting a destination host unreachable, and nothing that I have tried gets me to connect the two units, still directly connected to each other.

I tried adding adding a permanent route by creating a permanent route, and sadly the script did not yield a success.

I tried adding the two NICs to the hosts file, although that has nothing to do with route determination. I do not have a domain, so just IP1/"computer1" and IP2/"computer2". Adding the hosts file entries enables me to do "ping -c 3 computer2" from computer1 nicely, but still same message.

The interface definition is fine, works, comes up, all is good, but here is the interface file from computer2:

TYPE=Ethernet
BOOTPROTO=none
DEFROUTE=no
IPV4_FAILURE_FATAL=no
IPV6INIT=no
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME=ens2f0
ONBOOT=yes
HWADDR=00:0F:53:2A:18:B0
UUID=07f81988-6828-4b46-938a-72f70121e5a5
MTU=1500
IPADDR=15.5.53.51
PREFIX=24
GATEWAY=15.5.53.254

Here is the hosts file from computer2.

127.0.0.1       localhost localhost.localdomain localhost4 localhost4.localdomain4
::1             localhost localhost.localdomain localhost6 localhost6.localdomain6
11.33.41.15     computer1
15.5.53.51      computer2

From previous experience, I did both reboot the computer and subsequently turned off the computers and then back on, but same thing.

Thoughts?

  • unless you are using the IPv6, remove the line starting with ::1 from your hosts files. I saw this removal working miracles, reasons of which I am not so sure. – MelBurslan Aug 1 '16 at 17:20
  • @MelBurslan I tried that, but did not reboot/restart nework. Same thing. I am not using IPV6, just IPV6. – Sarah Weinberger Aug 1 '16 at 17:25
  • IP address of "11.33.41.15" and a default gateway of "11.33.41.0" What is the netmask of this? Because if it's just a /24 then the gateway is not valid. – Stephen Harris Aug 1 '16 at 17:30
  • @StephenHarris The two machines will be in different cities, but I wanted to test the 2 machines locally with their final IP addresses, so that the machines can be just plug and play. I also have a bit more to test and configure in other areas. – Sarah Weinberger Aug 1 '16 at 17:42
  • @SarahWeinbergerservice network restart after removing the IPv6 entries might be helpful. I am not sure. Grasping on straws here. – MelBurslan Aug 1 '16 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.