1

Platform: Ubuntu 11.10 64bit Kernel to be compiled: 3.2.1

Error after make: ERROR: "__modver_version_show" [drivers/staging/rts5139/rts5139.ko] undefined!

To solve this I copied the .config file of a previous build kernel on the same machine to the same one. Ran make menuconfig. Saved it without any changes. Ran make.

Make said that the bzImage is ready, but also gave the above error.

  • is your problem like this one ? – Coren Jan 25 '12 at 8:33
  • @Coren yes, and I have already tried that, didn't work, moreover that is the wrong forum for this question. – Aquarius_Girl Jan 25 '12 at 8:39
  • The kernel itself was compiled successfully, but not the modules. If the previous build was of a different kernel version, did you try make oldconfig? – Gilles 'SO- stop being evil' Jan 25 '12 at 23:17
  • related: superuser.com/questions/360089/… – rzr Feb 7 '12 at 17:47
1

It looks like the compiler or linker is dropping that function from the build since it cannot see any references to it... Did you tried this patch: https://lkml.org/lkml/2011/1/19/492? It didn't solve it for me.

  • Well, no I didn't try that. I have now compiled the Ubuntu's kernel 3.2.1 successfully, and removed the Kernel.org's 3.2.1. – Aquarius_Girl Jan 25 '12 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.