0

I just did a fresh install of CentOS 7 on my Asus EP121 tablet. The EP121 has touch and pen input.

During the install process the GUI install had working touch, much to my surprise.

After the install, X did not have working touch, but it seems to have Pen Input. ( or at least configuration software for wacom ). Unfortunately my pen is broken.

I have tried to install the egalax driver from ( http://www.eeti.com.tw/drivers_Linux.html ) which I read would work. Unfortunate it did not. In X I get the error egalax daemon not started when running the egalax software.

Since the touch input was working during install, I assume that the egalax driver is not really needed.

This is the output of xinput list | grep 'id='

Virtual core pointer                          id=2    [master pointer  (3)]
    Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
    Wacom ISDv4 90 Pen stylus                 id=13   [slave  pointer  (2)]
    eGalax_eMPIA Technology Inc. PCAP MultiTouch Controller   id=14   [slave  pointer  (2)]
    eGalax_eMPIA Technology Inc. PCAP MultiTouch Controller   id=15   [slave  pointer  (2)]
    Wacom ISDv4 90 Pen eraser                 id=18   [slave  pointer  (2)]

Virtual core keyboard                         id=3    [master keyboard (2)]
    Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    Power Button                              id=6    [slave  keyboard (3)]
    Video Bus                                 id=7    [slave  keyboard (3)]
    Power Button                              id=8    [slave  keyboard (3)]
    Sleep Button                              id=9    [slave  keyboard (3)]
    USB 2.0 Camera                            id=10   [slave  keyboard (3)]
    NOVATEK USB NETVISTA FULL WIDTH KEYBOARD  id=11   [slave  keyboard (3)]
    NOVATEK USB NETVISTA FULL WIDTH KEYBOARD  id=12   [slave  keyboard (3)]
    Eee PC WMI hotkeys                        id=16   [slave  keyboard (3)]
    AT Translated Set 2 keyboard              id=17   [slave  keyboard (3)]

This is the output of lsusb

Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 13d3:5122 IMC Networks 2M Integrated Webcam
Bus 001 Device 004: ID 0cf3:3005 Atheros Communications, Inc. AR3011    Bluetooth
Bus 002 Device 006: ID 0461:4e04 Primax Electronics, Ltd
Bus 002 Device 004: ID 056a:0090 Wacom Co., Ltd TPC90
Bus 002 Device 005: ID 0eef:a001 D-WAV Scientific Co., Ltd

How do I get touchscreen working?

0

After the eGalax driver install

I added the line

/bin/eGTouchD

to the /etc/rc.local file

I also had to do a

chmod +x /etc/rc.local 

To get it working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.