I've looked everywhere and nothing has worked. I am just trying to install skype.

I tried to see if it was in the repositories but didn't find it. So I wen't to the skype website and found a linux version but didn't know how to install it after extracting the tar file.

I then tried to loook in the AUR and found skype. But when I tried to run makepkg I get a

==> ERROR: PERMISSION was not found in the build directory and is not a URL.

I tried looking around for solutions but couldn't find anything. Every thread I found asks to cehck the /etc/pacman.conf file. Which I did and made sure I have the multilib included


# /etc/pacman.conf
# See the pacman.conf(5) manpage for option and repository directives

# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

#Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

I have look all over can't seem to find any solution.

  • My guess is yaourt skype. Do you have yaourt or a similar AUR client installed?
    – ddnomad
    Commented Jul 30, 2016 at 18:48

1 Answer 1


You are correctly using the Skype AUR package. Please follow the makepkg path of installing AUR packages (please do not get used to things like yaourt if you care about the security of your machine).

$ wget https://aur.archlinux.org/cgit/aur.git/snapshot/skypeforlinux-bin.tar.gz
$ tar zxf skypeforlinux-bin.tar.gz
$ cd skypeforlinux-bin
$ makepkg -s  # or install dependencies manually if you do not have sudo

The step that often fails is makepkg -s, which would install dependencies for the package. That command requires sudo which is not installed by default on Arch. Another option is to simply install the dependencies by hand before running makepkg. The AUR package page lists the dependencies and all are available from the default repositories (there are no AUR dependencies for skype).

This results in skypeforlinux-bin-1.x.x.x-x86_64.pkg.tar.xz (there is no support for i386 in this package, x.x.x.x stands for the current version of the package). The install it as root.

# pacman -U /path/to/package/skypeforlinux-bin-1.x.x.x-x86_64.pkg.tar.xz

Yet, and that is a very bit yet, the skype AUR package breaks often. People argue that it is because of Microsoft reworking the protocol too often without backward compatibility, or that the Debian package that is provided by skype/microsoft is never up to date to the actual skype. You can see a huge discussion about that on the AUR skype package page, in the comments.

As an Arch user what I do to use skype (and I do it only if I must) is that I install chromium:

pacman -S chromium

And the skype plugin for it.

Or even use the web app with:

chromium --app=https://web.skype.com
  • Thank you. This helped a lot. I got stuck on the dependencies part a while back but this clarifies the whole process of installing from the AUR. You're a life saver. Commented Jul 31, 2016 at 4:48
  • 3
    You should use skypeforlinux-stable-bin instead
    – OverCoder
    Commented Jan 13, 2018 at 21:22
  • 1
    Also to update the above answer, Use aurman instead of yaourt, as it is officially supported for arch, though the github repo has stopped taking bugs and PRs, aurman development is done privately. Also, use skypeforlinux-stable-bin instead, as @OverCoder said already.
    – phoenisx
    Commented Sep 30, 2018 at 13:13
  • 1
    And for those of us like me who can't remember the command, add alias skype='chromium --app=https://web.skype.com' in your .bashrc ;-)
    – Alexis
    Commented Oct 28, 2018 at 15:30
  • 1
    @thephoenix01 use something like "yay"
    – OverCoder
    Commented Jan 20, 2020 at 12:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .