3

I use openSuse Leap 42.1.

I had installed Skype long time ago. And it worked all the time. But recently it stopped start and when I run it from terminal I receive an error:

env: /usr/lib/skype/skype: Permission denied

I had googled this error but no luck. Now I have installed new version of Android Studio and when it runs and download SDK and tools it said:

Unable to run mksdcard SDK tool

I went to terminal again and run mksdcard in it and get an error:

bash: ./mksdcard: Permission denied

My last installation of the previous version of the Android Studio was successful. I have tried install previous version now and get this error too.

I consider that these errors have one nature. But all my research don`t bring me success.

Could someone help me to solve this problem?

migrated from askubuntu.com Jul 29 '16 at 18:09

This question came from our site for Ubuntu users and developers.

  • "Permission denied" means that, for some reason, the file couldn't be executed. Please include the output of ls -l /usr/lib/skype/skype and ls -l ./mksdcard. – JigglyNaga Jul 29 '16 at 18:17
  • -rwxr-xr-- 1 paola users 11819 Mar 22 2014 ./mksdcard – Paola Captanovska Jul 29 '16 at 18:23
  • is your home directory NFS mounted by any chance ? Please provide output from df -h ${HOME} – MelBurslan Jul 29 '16 at 18:26
  • 1
    strace skype should provide a lot more debug information about your problem. Could you attach a log? – MayeulC Oct 9 '18 at 9:09
  • 1
    @MayeulC, I finally moved to fedora and have no problems with skype anymore. but thank you – Paola Captanovska Oct 12 '18 at 3:06
1

Well, it really sounds like a Permission error. Have you checked the executables you are trying to run?

ls -l /usr/lib/skype/skype

This should output the permissions of the file (Read, Write, eXecute), respectively for the user, the group it belongs to, as well as the other users.

Since you are getting this error on more than one occasion, it sounds more like a group issue. You may for some reason no be a member of a required group. To tell what groups you are part of, you can use the groups command.

Of course, this is just an hypothesis.

  • -rwxr-xr-x 1 root root 36499124 Jul 28 18:36 /usr/lib/skype/skype – Paola Captanovska Jul 29 '16 at 18:20
  • Strange, the permissions look fine. It might be related to a file/folder skype (maybe mksdcard too) tries to access, so it may be related to the permissions in your home folder. – MayeulC Jul 29 '16 at 18:30
  • If it were easy I would have solved it myself ) – Paola Captanovska Jul 29 '16 at 18:43
  • 1
    Sure, but you can never know what has already been tried if not provided with ample details in the first place :) I've been trying to reproduce the issue on my side, without success for now. – MayeulC Jul 29 '16 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.