0

I would like to know if I can reclaim all of my storage. I do not need to recover data, I am free to be as invasive as I need to be.

Situation: two controllers, each with eight disks, two RAID sets (RAID6). One RAID set is handed off to the OS showing 2.2TB, the other shows 12TB.

I ran a deep scan using testdisk and it returned several dozens of "unrecoverable partitions" but I couldn't find a way to tell testdisk to just remove those partitions and give me all my space back.

testdisk has come back with: The harddisk (2199 GB / 2048 GiB) seems too small! (< 29 TB / 26 TiB) Check the harddisk size: HD jumpers settings, BIOS detection... (maybe there is a jumper or setting somewhere?)

Are the unrecoverable partitions preventing the OS from "seeing" the full size of 12TB? How can I remove unrecoverable partitions and get all of my disk space back?


Adaptec Controllers

Other than the following meaningless diffs, they are both Adaptec 5805 controllers running 1.2.0.30300:

root@system:~# arcconf getconfig 2 AD > /tmp/adapter2.info
root@system:~# arcconf getconfig 1 AD > /tmp/adapter1.info
root@system:~# diff /tmp/adapter1.info /tmp/adapter2.info
8,10c8,10
<    Controller Serial Number                 : xxxxxxxxxxx
<    Physical Slot                            : 3
<    Temperature                              : 77 C/ 170 F (Normal)

>    Controller Serial Number                 : yyyyyyyyyyy
>    Physical Slot                            : 4
>    Temperature                              : 76 C/ 168 F (Normal)

RAID sets

The RAID sets are as I'd expect according to the RAID controller's mgmt tool, arcconf:

root@system:~# arcconf getconfig 1 ld
Controllers found: 2
----------------------------------------------------------------------
Logical device information
----------------------------------------------------------------------
Logical device number 0
   Logical device name                      : STORAGE1
   RAID level                               : 6 Reed-Solomon
   Status of logical device                 : Optimal
   Size                                     : 11427830 MB
   Stripe-unit size                         : 256 KB
<...snip...>

root@system:~# arcconf getconfig 2 ld | more
Controllers found: 2
----------------------------------------------------------------------
Logical device information
----------------------------------------------------------------------
Logical device number 0
   Logical device name                      : STORAGE2
   RAID level                               : 6 Reed-Solomon
   Status of logical device                 : Optimal
   Size                                     : 11427830 MB
   Stripe-unit size                         : 256 KB
<...snip...>

OS programs

lsscsi output:

root@system:~# lsscsi -s | grep Adaptec
[0:0:0:0]    disk    Adaptec  STORAGE1        V1.0  /dev/sdc   2.19TB
[7:0:0:0]    disk    Adaptec  STORAGE2        V1.0  /dev/sdd   11.9TB

testdisk reports:

Disk /dev/sdc - 2199 GB / 2048 GiB - CHS 267349 255 63
Disk /dev/sdd - 11 TB / 10 TiB - Adaptec STORAGE2

After a scan, testdisk shows several partitions:

The following partitions can't be recovered:
     Partition               Start        End    Size in sectors
>  MS Data                    52734 19503545853 19503493120
   MS Data                    52736 19503545855 19503493120
   MS Data                   262654 19503755773 19503493120
   MS Data                   262656 19503755775 19503493120
   MS Data                   367102 19503860221 19503493120
   MS Data                   367104 19503860223 19503493120
   MS Data                  1311742 19504804861 19503493120
   MS Data                  1311744 19504804863 19503493120
   MS Data                  1312254 19504805373 19503493120
   MS Data                  1312256 19504805375 19503493120
<...snip...>

lsblk also only shows 2TB:

root@system:~# lsblk
NAME                 MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sdc                    8:32   1     2T  0 disk
sdd                    8:48   1  10.9T  0 disk

Other things

I've tried:

1.) Use dd to write all zeros to the full disk but it only wrote to 2.2TB until stopped with the message "No space left on device". Again, only writing to 2.2TB of space.

root@system:~# dd if=/dev/zero of=/dev/sdc bs=8M
dd: error writing ‘/dev/sdc’: No space left on device
262145+0 records in
262144+0 records out
2199023255552 bytes (2.2 TB) copied, 2870.71 s, 766 MB/s
root@system:~# fdisk -l /dev/sdc

Disk /dev/sdc: 2 TiB, 2199023255552 bytes, 4294967296 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

2.) Use parted to remove all partitions and just hand the OS an unpartitioned drive.

root@system:~# parted /dev/sdc
GNU Parted 3.2
Using /dev/sdc
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print
Error: /dev/sdc: unrecognised disk label
Model: Adaptec STORAGE1 (scsi)
Disk /dev/sdc: 2199GB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags:

3.) I've attempted to rebuild the RAID set, deleting and recreating the RAID set, and smartctl scanning all disks. No change.

4.) gpart /dev/sdc returns some stuff but doesn't suggest that I can do much about it (just returns me to my prompt, doesn't stay in gpart interactive mode).

root@system:~# gpart /dev/sdc

Begin scan...
End scan.

Checking partitions...
Ok.

Guessed primary partition table:
Primary partition(1)
   type: 000(0x00)(unused)
   size: 0mb #s(0) s(0-0)
   chs:  (0/0/0)-(0/0/0)d (0/0/0)-(0/0/0)r

Primary partition(2)
   type: 000(0x00)(unused)
   size: 0mb #s(0) s(0-0)
   chs:  (0/0/0)-(0/0/0)d (0/0/0)-(0/0/0)r

Primary partition(3)
   type: 000(0x00)(unused)
   size: 0mb #s(0) s(0-0)
   chs:  (0/0/0)-(0/0/0)d (0/0/0)-(0/0/0)r

Primary partition(4)
   type: 000(0x00)(unused)
   size: 0mb #s(0) s(0-0)
   chs:  (0/0/0)-(0/0/0)d (0/0/0)-(0/0/0)r
  • 1
    I'm voting to close this question as off-topic because it has nothing to do with unix or linux. your hardware raid controller is telling linux that there is one 12TB disk and one 2.2TB disk. – cas Jul 29 '16 at 2:35
  • I tried posting this in Stackoverflow and they closed it as being a Linux issue. testdisk can see more partitions so I'm not sure where to go for assistance. The RAID sets are 2x12TB but by the time the OS gets them, they're 12TB and 2.2TB. Are you suggesting my RAID controller is going bad? Close this if we must; I guess I'm left with swapping out hardware. – harperville Jul 29 '16 at 13:45
1

Well, after performing the following:

arcconf delete 1 logicaldrive all
arcconf tast start 1 device all intialize
arcconf CREATE 1 LOGICALDRIVE Name STORAGE1 blah..blah...

I now have what I'd expect:

root@system:~# lsscsi -s | grep Adaptec
[0:0:0:0]    disk    Adaptec  STORAGE1         V1.0  /dev/sda   11.9TB
[7:0:0:0]    disk    Adaptec  STORAGE2         V1.0  /dev/sdc   11.9TB

Problem solved. Hardware seems fine.

  • 1
    good to see you fixed it. You mentioned that you didn't need to retrieve data from the drives, so I assume you're in the early build and test stages. I'd suggest configuring one of the adaptec controllers in JBOD mode, and comparing performance (using bonnie++) with HW RAID6 vs mdadm RAID6. If you've got (or can install) an SSD, test mdadm again while using bcache. And then, test performance again using RAID-10 (total of 8TB rather than 12TB). with and without bcache. Finally, try btrfs and/or ZFS on JBOD. – cas Jul 30 '16 at 4:11
  • Other useful refs: btrfs. ZFS On Linux. See also Why RAID 6 stops working in 2019. Google will find you a lot more info but beware of old pages with outdated info (esp. for btrfs). BTW, don't use btrfs or zfs on top of other (SW or HW) RAID - you lose one of their most useful features (bitrot/error detection and correction) – cas Jul 30 '16 at 4:12
  • Thank you very much, @cas I appreciate the tips to explore other options! Great learning experience. – harperville Jul 31 '16 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.